pinging at 1/4 throttle roll on


8 replies to this topic
  • 01cr80

Posted 30 April 2012 - 09:00 PM

#1

i got my 1993 cr250 out for the first time this weekend and it was running good but was a little boggy off idle. I have the jd kit and according to it all you should ever change is the needle and maybe the main. So i changed the blue needle 3rd pos clip to the red one which is leaner 0-1/4 throttle, 3rd clip pos, and air screw best at 2 turns out. And now the bike runs amazing! no bogging anywhere and very very crisp through all rpms. But, when the motor is under load it pings 7-15 times like when you are going up a hill in too high of a gear. At least im 90% sure its pinging. It sounds like a metallic sound but i have to listen hard to hear it. No power difference or any difference in the way it runs, just the noise. So i went back to the needle it had before which is slightly richer and it runs like crap but the pinging is mostly gone, very boggy and cannot get the air screw set right, it needs to be 4+ turns out to even idle. So i went back to the red (leaner) needle and tried some 110 sunoco race fuel from my grandpas late model. Its not there as much but it still pings a little. So idk if i need to change the main jet or what but im lost. Any help will be appreciated!!

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • frdbtr

Posted 01 May 2012 - 04:22 AM

#2

You may have an air leak. Check your stator side crankshaft seal. My 125 was doing that when the crankshaft seal was blown.

  • HRC27

Posted 01 May 2012 - 09:31 AM

#3

Main jet is barely coming in at 1/4 throttle so I don't think that's it. Did you try the stock needle? I would give that a shot and play with the needle clip.

Posted Image

  • 01cr80

Posted 01 May 2012 - 10:06 AM

#4

i forgot to mention it has a pwk airstryker off a 99 cr250 and the jetting was very far off with the stock jetting so i bought the jd kit and have it pretty close now besides the pinging

  • ryanmac

Posted 01 May 2012 - 10:31 PM

#5

Maybe leave the blue needle in but go i clip position down, richening the mixture just a little but enough?

  • 01cr80

Posted 02 May 2012 - 05:30 AM

#6

tried that and it still runs like crap...i rode it yesterday for a while and there was no pinging so i might just leave it alone for a while

  • Third-Reef

Posted 02 May 2012 - 06:19 AM

#7

Pinging is a known problem, so run 1/2 race gas and jet till it runs good

  • 01cr80

Posted 02 May 2012 - 08:02 AM

#8

thats what i just did, half 110 octaine sunoco and half 91 pump gas, no pinging yet!!

  • 2strokes4me

Posted 02 May 2012 - 11:00 AM

#9

Have you checked timing? If timing is right, and it sounds like your jetting is pretty close, then I would reduce compression with a little head work. Pre-detonation is hard on bearings, and running race gas is inconvenient imo.





Related Content

Forums
Photo

CR500AF MX Project.. Is it possible to tame? by superfatcat22


Dirt Bike   Make / Model Specific   Honda   Honda 2-Stroke
  • Hot  50 replies
Forums
Photo

Another pwk thread, 05 cr125, YZ pwk by zotis777


Dirt Bike   Make / Model Specific   Honda   Honda 2-Stroke
  • Hot  32 replies
Forums
Photo

How long would a 2004 cr125 last? by Michaelthebeast


Dirt Bike   General Dirt Bike Forums   What bike should I buy?
  • Hot  28 replies
Forums
Photo

Advice and Tips for my 04 Honda CR250R by DC75


Dirt Bike   Make / Model Specific   Honda   Honda 2-Stroke
  • 7 replies
Forums
Photo

1995 rm80 by rohan1234


Dirt Bike   Make / Model Specific   Suzuki   Suzuki 2-Stroke
  • 0 replies
 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

Register Close
If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.