yzf 426 coolant issue


2 replies to this topic
  • mrweehorn

Posted April 22, 2012 - 08:26 AM

#1

does anyone have any idea why there would be what looks like copper filing in the rad water on a 04 yzf 426 . ?

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • grayracer513

Posted April 22, 2012 - 08:30 AM

#2

There is no '04 426. The 426 was '00-'02. '03 and later are 450's.

The only thing that comes to mind is some kind of stop-leak additive.

  • mrweehorn

Posted April 22, 2012 - 08:36 AM

#3

yeah thats what i was thinking . but the man who i bought it off said he d never noticed . and i just noticed i had said an 04 when i meant 02 .. must be something thats been added to the water ... im new to 4 strokes but but can t think off anything copper that could contaminate the water . just got the bike today so think tomorrow im gonna give it a right good service





Related Content

Forums
Photo

2016 YZ450 by CaptainKnobby


Dirt Bike   Dirt Bike Technical Forums   Suspension
  • Hot  59 replies
Forums
Photo

James Stewart back on a YZ450F by YamaLink


Dirt Bike   Special Interest Forums   Pro Racing
  • Hot  47 replies
Forums
Photo
Motocross

Thinking about Yamaha 250... by Arctic Pride


Dirt Bike   Special Interest Forums   Pro Racing
  • Hot  491 replies
Wiki
WR Camshaft Swap Info - last post by jamesm113

WR Camshaft Swap Info


Articles
  • 0 replies
Forums
Photo

YZ450F 03 Sparks driving me crazy by SirAttard


Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • 5 replies
 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.