Gets really hot really fast


11 replies to this topic
  • proamature

Posted April 20, 2012 - 06:00 AM

#1

My bike gets abnormally hot really fast. Like 30 seconds after a cold start. Feels like I've been riding it all day. Could this be a result of running to lean? If so. How many turns out do y'all do? Also could the problem be that the water pump is leeking out the water pump through the weep hole.? Got the parts comming.. Was jus curious. Thanks

Edited by 99wr400POS, April 20, 2012 - 06:16 AM.


  • Stealth13

Posted April 20, 2012 - 06:07 AM

#2

My exhaust can burn my hand after 30 seconds of it being on. They all heat up quick and you need to ride it and not let it sit.

  • proamature

Posted April 20, 2012 - 06:16 AM

#3

Oh so yours does it to?

  • Stealth13

Posted April 20, 2012 - 06:26 AM

#4

Not just mine , all of them. They can't even idle more than 5-10 mins without spilling coolant out.

Thats why you see people asking about rigging up a fan to help cool it down

Edited by Stealth13, April 20, 2012 - 06:26 AM.


  • Just_a_trail_rider

Posted April 20, 2012 - 06:46 AM

#5

My bike gets abnormally hot really fast. Like 30 seconds after a cold start. Feels like I've been riding it all day. Could this be a result of running to lean? If so. How many turns out do y'all do? Also could the problem be that the water pump is leeking out the water pump through the weep hole.? Got the parts comming.. Was jus curious. Thanks


Obviously, youi have to deal with the water pump problem.

After that, deal with your jetting. Its not simply a matter of turning out the fuel screw. You have to have the right pilot jet first, then adjust the fuel screw accordingly.

See the jetting guide, of simplify your life and get the JD jetting kit like many of us do.

  • proamature

Posted April 20, 2012 - 06:48 AM

#6

Ohhhh ok. Well thank y'all for the help. I didn't know if it was normal or what.this is the first 4stroke I've owned. Starting to like em.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • woods-rider

Posted April 20, 2012 - 06:53 AM

#7

Uhh, mine can idle for more than 15 min (maybe more, but haven't tried) without spilling a drop of coolant. Fix that water pump leak then if you are still having problems maybe try changing out your coolant if it's old.

  • freeriders98

Posted April 20, 2012 - 12:13 PM

#8

I've got a Vapor computer on mine, and starting up cold and letting it idle 2-3 minutes it is easily at 150*

  • Frostbite

Posted April 20, 2012 - 01:34 PM

#9

At -40 my 99 would boil over at idle.

  • GlennR

Posted April 20, 2012 - 03:37 PM

#10

At -40 my 99 would boil over at idle.


That would be a chilly ride!! :thumbsup:

  • Stealth13

Posted April 21, 2012 - 01:02 PM

#11

Mine is overheating as I type this... Climbed a long mountain in gear 1

  • Krannie McKranface

Posted April 21, 2012 - 02:26 PM

#12

Re-jet, get a higher pressure radiator cap, and be done with it.




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.