09 yz450. Oil pressure/oil smell issue!


10 replies to this topic
  • jonsson_

Posted April 14, 2012 - 09:34 AM

#1

Hi guys! I have some issues with my 09 yz450. The last couple of rides before winter it smelled alot of oil... didnt loose any though. Now when i brought it to life after the winter i noticed no oil on the dipstick... Puzzled me abit but I just changed oil and filter and thought it should be fine.
1L of oil no oil on stick... Idled it some more and checked oilpressure screw. It started getting oily so I tightened it right back up like I use to. But still nothing on the stick... Added more oil ran it in front of the house back and forth, nothing.. Hmmm.... Rechecked pressure screw and its moist but doesnt dripp! Removed check bolt for oillevel on crankcase and quite alot of oil poured out.
Removed oil filter cover and turned engine over, oil gets pushed to the filter. Put it back on and opened up the flywheelcover, oil is pushed out to the cover. oilpassage in cover is clear. Passage to tank is also free. (Blew through them)
HELP! Ideas?


Regards: Anders

  • DC_Excitement

Posted April 14, 2012 - 04:19 PM

#2

so your checking oil pressure through the bolt on the head and it dosent come out? sounds like a possible clogged channel problem or maybe a rare oil pump failure

  • jonsson_

Posted April 15, 2012 - 12:39 AM

#3

Yes. And no oil on the dipstick. The oilchannel to the head origins from where?

  • jonsson_

Posted April 15, 2012 - 08:30 AM

#4

I dont understand why it doesnt fill the oiltank?? When running the dipstick gets oil on it which indicates that the oil is circulating but when I shut it off, no oil on stick!
Removed breather hose between oiltank and crankcase, cant blow air through it UNLESS I remove dipstick = tank OK.
Headvent not obstructed.
Blew compressed air from oilpressure checkscrew on the head and it comes out in the breatherhose and dipstick hole.
Oil IS slowly coming out of the checkscrew now.

Emptied oiltank right after shut down, 90cc drained. How much is normal? I think it was much more before but I never measured the amount then.

  • skull1971

Posted April 16, 2012 - 12:05 PM

#5

A question, how long are you running it before shut down and checking the oil? and I have an 08, basically the same bike and just 1L of oil on a change is not enough. Mine takes 1.2L to fill it, tank and to bottom of the level check hole.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • grayracer513

Posted April 16, 2012 - 01:17 PM

#6

One of two things is happening. Either the oil is being returned to the tank too slowly because of a fault with the scavenging pump (inner rotor set) or a venting issue, or there is a hole in the oil tank leading back to the crankcase. Because of what you said regarding the vent line, I doubt the tank is faulty.

  • grayracer513

Posted April 16, 2012 - 01:21 PM

#7

A question, how long are you running it before shut down and checking the oil? and I have an 08, basically the same bike and just 1L of oil on a change is not enough. Mine takes 1.2L to fill it, tank and to bottom of the level check hole.

The bike should not be filled until oil runs out the check hole after the tank is full. It is full when you have added enough oil to reach the "full" mark on the dip stick following 1-3 minutes of operation. One liter does this perfectly after an oil change with filter. Adding more than that forces oil out of the tank back to the sump, where it basically just gets in the way.

  • jonsson_

Posted April 18, 2012 - 08:03 AM

#8

Took the oilpump out and there´s nothing wrong with it. Only thing that can be wrong is the "pin" right? It spins free and I cant find anything wrong... I´ve used compressed air in every oilpassage I can find. Nothing out of the ordinary.. Although I havent had a oildelivery problem before so I dont know what to look for... But I´m no newbie wrenching on engines.

  • jonsson_

Posted April 18, 2012 - 12:38 PM

#9

Oilstrainer was partially blocked. Managed to clean it good enough.. Wish that strainer could be removed without spliting the case! I think I´ve picked up "wetland grass" (called "myr" in swedish) through the breather... I doubt it can get passed the airfilter!?

  • grayracer513

Posted April 18, 2012 - 01:07 PM

#10

Oilstrainer was partially blocked. Managed to clean it good enough..


That would explain it. The screen can be back flushed from the oil pump pocket, and you can get at the bottom of it to an extent by removing the flywheel cover.

  • jonsson_

Posted April 19, 2012 - 09:58 AM

#11

Exactly what I did! :thumbsup:





Related Content

Forums
Photo

Is it worth it? (Cam and High compression piston) by macgi77


Dirt Bike   Make / Model Specific   Honda   CRF 150/230 F/L
  • Hot  36 replies
Forums
Photo

2016 YZ450 by CaptainKnobby


Dirt Bike   Dirt Bike Technical Forums   Suspension
  • Hot  59 replies
Forums
Photo

yz250x vs 450 4t comparisons (preferably desert riding) needed by JakeNorthrupYZ450F


Dirt Bike   Make / Model Specific   Yamaha   Yamaha 2-Stroke
  • 9 replies
Forums
Photo

Chubby dad, looking at bikes , First trip to the orange/black forum ! by Slow_ride


Dirt Bike   Make / Model Specific   KTM   250-530 EXC/MXC/SXC/XC-W/XCR-W (4-Strokes)
  • Hot  28 replies
Forums
Photo

James Stewart back on a YZ450F by YamaLink


Dirt Bike   Special Interest Forums   Pro Racing
  • Hot  47 replies
 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.