problem with clutch when engine gets hot


No replies to this topic
  • CaocaoWR

Posted March 25, 2012 - 06:04 PM

#1

I have own an 07 for half a year and am really in love with it. Recently I discovered some problem with its clutch which makes me really annoying.
The symptom is that when the engine gets pretty hot after about an hour riding (which I can really feel the heat under my pants), the engine is easy to get stall when I am in in 2nd/3rd or higher gear and have to slow down rapidly, even though I have pulled the clutch (all the way in). After last ride, I opened the clutch and check all the plates and hub, and every thing is in specs as in the Manual. Today riding, I have the problem again, got the bike stall two or three times in tricky terrain.
It seems that the clutch does not fully dis-engage when the lever is pulled.
Some of my friends told me that they have experienced the similar situation with Yamaha bike.
Is anyone have the same case? Is there any cure for the clutch or it's just my riding skill. If I can down shifted quickly enough to 1st gear, pull the clutch and give it a blip than it will be okay. In some case it's not that easy. :thumbsup:




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.