Re setting my TPS?


7 replies to this topic
  • maddshaggy

Posted March 13, 2012 - 04:41 PM

#1

I accidently pulled out my TPS. What do I have to do to put it back in the right position?
thanks!

  • GCannon

Posted March 14, 2012 - 10:24 AM

#2

First set the idle speed and mixture perfect!

Look in the manual, You will need low impedance (good quality) volt meter or a Digital storage oscilloscope (lab scope). You will need to back probe the TPS connector with pins while the connector is connected. with the engine running at idle adjust (move ) the TPS to the desired voltage range. My 02 had a range of .45 to .75 volts I set mine to high side of the allowable range (.72) in an attempt to lessen the part throttle stutter. It did help. check your manual to see what your recommended voltage range is.

The TPS is a sensor input which the ignition module uses to adjust ignition timing within the 3D mapping.

  • grayracer513

Posted March 14, 2012 - 11:35 AM

#3

That's all correct info. An old mechanic's trick with things like that is to use the "witness marks", the impressions, marks, etc., left on one part by another or on a part by the fasteners that bolt it in place to get close to the original location to start with.

You didn't mention the year model. This is not too difficult on steel framed bikes, but the Gen2 450's with the aluminum frames make this much more difficult due to the limited access to the carb. With those, what works best is to leave the TPS just loose enough where it can be rotated in place, but tight enough not to move on its own, then run the bike while the sub frame is still removed to make any necessary adjustments. I shortened an Allen key so I could reach in and tighten or loosen the TPS from behind. PITA? You betcha....

  • maddshaggy

Posted March 14, 2012 - 06:27 PM

#4

I have an 03 WR450. Thank you for the info!

Edited by maddshaggy, March 14, 2012 - 06:29 PM.


Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • stuntheavy

Posted March 16, 2012 - 05:55 PM

#5

First set the idle speed and mixture perfect!

Look in the manual, You will need low impedance (good quality) volt meter or a Digital storage oscilloscope (lab scope). You will need to back probe the TPS connector with pins while the connector is connected. with the engine running at idle adjust (move ) the TPS to the desired voltage range. My 02 had a range of .45 to .75 volts I set mine to high side of the allowable range (.72) in an attempt to lessen the part throttle stutter. It did help. check your manual to see what your recommended voltage range is.

The TPS is a sensor input which the ignition module uses to adjust ignition timing within the 3D mapping.


I believe you mean high impedence multimeter. Low impedence are the old analog style, which do exciting things to circuit boards.

TPS is a nightmare on these bikes, it seems.

  • GlennR

Posted March 24, 2012 - 10:41 AM

#6

That's all correct info. An old mechanic's trick with things like that is to use the "witness marks", the impressions, marks, etc., left on one part by another or on a part by the fasteners that bolt it in place to get close to the original location to start with. You didn't mention the year model. This is not too difficult on steel framed bikes, but the Gen2 450's with the aluminum frames make this much more difficult due to the limited access to the carb. With those, what works best is to leave the TPS just loose enough where it can be rotated in place, but tight enough not to move on its own, then run the bike while the sub frame is still removed to make any necessary adjustments. I shortened an Allen key so I could reach in and tighten or loosen the TPS from behind. PITA? You betcha....



Thanks for the tips. I was wondering how to adjust the TPS on the fat aluminum frame bikes, it looks like a PITA.....but good to hear that it is "possible".

  • highmarker

Posted March 24, 2012 - 10:54 AM

#7

off topic but.........Some bikes that are subject to noise emission standards have a tps adjusted map that doesn't give as much advance in the timing at certain rpms, takes a little bark out the exhaust. So don't be afraid to try it with it unplugged,

Edited by highmarker, March 24, 2012 - 10:55 AM.


  • GlennR

Posted March 25, 2012 - 07:30 AM

#8

I tried it unplugged. At first I thought it stuttered less, but towards the end of my ride it seemed as bad as before.

The electrical connectors looked a little dirty when I unplugged them. I'll clean them & measure the resistance and reconnect the TPS (if i measures "good"). Hopefully that will get it to smooth out. If not I guess I'll loosen the TPS mount and play with the positioning some.

Seems strange Yamaha didn't work out the bugs better on the TPS.




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.