Magura clutch on WR450F

1 reply to this topic
  • nfplunkettjr

Posted March 12, 2012 - 06:44 PM


I just installed a new Magura hydraulic clutch on my '09 WR...looks and works great. I have a problem with the hot start cable. The clutch perch has a threaded area next to the the hot start lever- it looks like the cable is supposed to thread into the housing on the perch...obviously the stock cable isn't threaded. The directions that came with the unit isn't very helpful. I tried finding a tech support number for Magura, all I could find was an online help email address. Hopefully someone has some experience with this. Thanks.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • MaxPower

Posted March 13, 2012 - 08:54 AM


Im going to pm you my number and email
could you text pic or email pic the mount?
I bought one from ebay.The seller had made a cheesy home made mount
It kind of works .Put the pull at a weird angle.
I want to make something or better yet order the correct part . And want to see if it works on my bike
I am using a Dr D right side hot start on mine


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.