New Scotts Damper Question 2011 WR

5 replies to this topic
  • Traskrider

Posted March 06, 2012 - 04:57 PM


wicked good quality piece !!! but anybody w ith the over the bar mount notice some flex in the tower at all when riding ? I notice the tighter I set the damper the more movement I get from the main tower mount. normal ?

  • beezer

Posted March 06, 2012 - 05:05 PM


You have to make sure the tower fits the steering head perfectly. I had to file the steering head on mine.

  • dustdogg

Posted March 06, 2012 - 05:28 PM


You also need to take your time and carefully select the proper fitting washer where it mounts with the tank. I had mine loosen up several times so I had to make sure the steering head was fitting properly and a change in washer thickness finally took care of mine. On my other bike I have the sub mount and because it has a much shorter post it doesn't see the same leverage as the over the bar setup and never once has it shown any signs of flexing or loosing up. Just make sure to take your time with the install and it will work great!!

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Eric@ScottsPerformance

Posted March 07, 2012 - 04:41 PM


Keep in mine that you can make the damper so tight as to create a hydraulic lock and you can break of the towers if you really wanted to. In real world riding conditions its not going to happen but if you set the damper tight on the stand and wiggle the bars back and forth you will make that bracket flex and eventually work its way off and if its a tower thats been welded onto a steel frame bike it will break off. What year is your bike and how many clicks out from full hard is your damper?

  • Traskrider

Posted March 09, 2012 - 05:18 PM


Thanks guy's for the info I am rechecking things in the Morn. I will check to see if the tower is tight on there again, the washer I think i got that dialed in ok, Thanks for the heads up Eric on what these can do, my first one so it's all new to me. My Bike is a 2011 WR 450, as far as the clicks out I went out and checked when you asked and it was 24 clicks, so pretty tight. I went back and started at 8 clicks tested and no movement then 1 click at a time and at 12 clicks out the tower started to move and I can also feel the base move a bit to, so I will pull it apart and recheck the base, i'm pretty sure that my issue.

  • Traskrider

Posted March 15, 2012 - 07:17 PM


Thanks for the help Guys !! went back to square one and found that the base wasnt all the way down flush, I ground the high spots down and got it to fit just right. Much better fit and no wiggling from the tower. Thanks again !!


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.