Please help with my NX/XR650L Motard Hybrid



1 reply to this topic
  • REMOTARD

Posted October 10, 2003 - 08:17 PM

#1

Thanks in advance for looking!!!. I have a fresh motor in my NX650. The motor is froma 97 XR650L. All of the smog junk has been removed. Here is the problem. Gas does not want to run from the tank to the carb, before you point out the obvious yes I have gas and no the filter is not clogged. If i pull the fuel line it runs fine. I think it has to do with a plugged vacuum hose. There is a hose which runs from one side of the carb to the other, over the top and through a metal tab. It used to have a tee but I removed the tee instead of plugging it. Does anyone know if i need to vent these lines to atmosphere???? The bike runs but I can see that the fuel is clearly not filling the fuel line. Thanks for all your help.. I will post pics of the GSXR wheeled/braked monster soon!!! :)

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • MotoChris521

Posted October 12, 2003 - 05:51 AM

#2

Yo ,
you say the bike runs ?then you must be getting gas to the carb.does it have a lack of power or any running problems?i have a see thru filter on two of my bikes and the gas never completely fills them.Yes the carb (and tank)have to be vented or fuel wont flow.good luck! :)





Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.