front brake help


5 replies to this topic
  • stlyamadude

Posted December 18, 2011 - 10:25 AM

#1

08 yz450f. I have had front brake problems since I bought it used.....I have put a brand new stainless galfer line...oem new master cylinder and a caliper rebuild kit...bled the line multiple times and still do not have a great front brake...o n new pads also....it was ok after I did all of it for about a month but now its kinda back to .......idk less than medioker....lol. I rode a 09 yesturday with all stock brakes and they were freaking awesome!!!!!! Help!!!! What and y is wrong with her??????

  • 2grimjim

Posted December 18, 2011 - 10:35 AM

#2

Probably still have some air trapped in the brake system. They are a real p.i.t.a. to bleed. Did you try bleeding the front brake again?

  • ubu

Posted December 18, 2011 - 10:48 AM

#3

Does it have the original level, or has it been replaced?
http://www.thumperta...853#post5844853
I know it's common to have lock up problems with aftermarket levers from the wrong years, but I had a soft brake and bleeding problems with my incorrect lever. I bent my stock lever and grabbed an aftermarket one at the dealer. Rode for a while with a mediocre brake, replaced pads thinking they were part of the problem, then it would not bleed. Put the bent stock lever on and it bleed instantly. Then, I got the proper lever for my 08 and it's been great. I think the same master cylinder piston travel issue was causing my bleeding problems.
Thankfully, it never locked up as I probably never got it hot enough. That would make for a long day in the desert.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • 2smokeforlife

Posted December 18, 2011 - 05:55 PM

#4

Probably still have some air trapped in the brake system. They are a real p.i.t.a. to bleed. Did you try bleeding the front brake again?


^^^what he said... you might want to get e new rotor might be warped. or out of spec.

  • stlyamadude

Posted December 19, 2011 - 05:38 PM

#5

thanks guys...ya know i got a lever for it at first n it was the wrong one...the guy at the bike shop actually argued with me that it was rite...lol ya i showed him...i got another after market and it fit but i wonder if it is not deep enough like u guys have explained...i have been busy with work so havnt had achance to check it yet but will def..i am also going to re bleed again..have to change my front line any way cas it got cought behind my plater and stuck on the top pinch bolts and messed up my line,just order a new one and will do all when it comes n tomorrow...i will keep in touch if i get it fixed...i ahve checked the rotor and i dont think that is it either...idk hope new line and bleeding fixes it..ive read that the galfer lines have been known to be bad so maybe thats my problem...did not order another..ges ill see n a few days..wish me luck thnks guys

  • stlyamadude

Posted December 21, 2011 - 05:05 PM

#6

ok so i checked the lever last night to see if the pilot hole wasnt dep enough and putting preasure on the piston but as it turns out not the case...i can pull the bolt out of the lever and the piston fit snug with the lever bolt hole lined up so obviosly thats not a my problem...i checked for leaks....none...i am going to bleed it all out later and see where that gets me...what sucks is even after i work on it i cant try it out short off pulling the lever while sitting on a stand...lol have no wheere to really ride so will have to wait a few weeks till the next ride to se if ive fixed it...so good luck to me ha ha and all have great xmas and new year!!!!!!!!





Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.