2007 WR450 Cutting out


3 replies to this topic
  • mxpx1359

Posted November 14, 2011 - 10:54 AM

#1

I have a 2007 WR450 that I converted to a supermotard. The bike runs flawlessly until I run it hard. Even 2 minutes on the freeway at high RPM's and the bike will start to sputter and eventually shut off. It will start back up with no problems. Really weird. When riding around town not at high speeds it will also run flawless. ANY IDEAS... NEED HELP!

  • zibbit u2

Posted November 14, 2011 - 12:06 PM

#2

to me I'd check spark. When's the last time you put a new plug into it?

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • MaxPower

Posted November 14, 2011 - 02:00 PM

#3

to me it sounds like you are running out of fuel. Bike sits.Gas trickles into the bowl and you're ready to go again.
Check fuel line flow + Amount of gas in the tank.Maybe clean the fuel valve screen.Check your gas cap breather line not to be kinked.
If it still does it pull off the little one way in line valve in the breathed tube.I've seen them fail as aftermarket parts,never a OEM part yet.But something is wrong with your bike


  • Krannie McKranface

Posted November 14, 2011 - 08:21 PM

#4

+1 fuel starvation




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.