Adjust TPS or just unplug it and forget it?

16 replies to this topic
  • zlathim

Posted November 13, 2011 - 07:01 PM


My 2001 WR 426 has a high RPM stutter at approximately 1/8 throttle. It will spit and sputter at 1/8 throttle, but revs out just fine when you twist the throttle further.

After messing around with the fuel screw without having any affect on the stutter, I unplugged my TPS and the problem instantly went away. Using the manual as a guide, I checked the TPS coil resistance, and it was within specs at about 4.2K ohms. I then attempted to check the ohm "sweep" as I opened the throttle. Resistance started out at about 700 ohms, then swept upward to about 2k ohms (throttle opened 1/3), then the meter went to open for the rest of the throttle opening (from 1/3 to WOT). I want to try to adjust the switch to see if I can straighten it out, but I have to wait until I can get a security torx bit to losen the mounting screws. I'll get one tomorrow, but in the meantime I thought I would see if anyone here had experienced anything like what I am dealing with.

Have any of you guys had any luck adjusting the TPS? I know some guys just disconnect the TPS and leave it like that. I assume that if you just unplug it and leave it, you lose some functionality of CDI's ability to vary ignition timing depending on throttle position, but how much does it really matter?

Any thoughts and opinions are welcome.

  • Sknight

Posted November 13, 2011 - 09:57 PM


If the TPS is going open after a certain point adjusting it won't change anything. I've got mine connected but lots of folks leave it unplugged and seem to do just fine.

If mine went out I'd replace it unless it's stupid expensive. Too expensive I'd unplug and try it.

  • Krannie McKranface

Posted November 14, 2011 - 07:22 AM


Leave it unplugged for a few rides, then on you next 'real' dirt ride, plug it in after a few miles. You will notice a snappier powerband.

I left mine unplugged for a years, and never went back. Never could get the TPS adjustment to make a big enough improvement, and the bike ran fine without it.

  • GCannon

Posted November 14, 2011 - 08:38 AM


I have had good luck adjusting my TPS on the 426.

You need to review your manual to start. The very first think you need to to do is adjust you idle speed and mixture until it is perfect.

Then you will need to get a good meter or lab scope to check TPS voltage while the bike is running. you will need to use pins and back probe the TPS connector.

Then adjust to the high side of the voltage range i believe the manual gives a range and the high side is .75 volts at idle (throttle closed) You need to check this on your own.

I adjusted mine at idle up to .73 volts. Then ride the bike for a while. my shudder was reduced significantly. it is now only detectable when riding on pavement at 1/4 throttle. I never notice it in the dirt.

The final mod I did was to raise the needle 1 slot to richen up the low speed operating area where the shudder occurs in an attempt to smooth out the 1/4 throttle operating area.

  • zlathim

Posted November 14, 2011 - 11:32 AM


Thanks for all the info guys.

SKnight is right, my TPS is junk. I messed with the adjustment today, but it didn't change the fact that there is an open circuit at about 1/2 throttle.

The local dealership is closed today, so tomorrow I will call and find out the price and availability of a new TPS and go from there. Unless it is <$30, I will probably just leave it unhooked.

Thanks again for the help.

  • MaxPower

Posted November 14, 2011 - 11:37 AM


im thinking the spot you are looking for has to be close to your original setting.Rather than go the techno route can't you carry that funny torx socket and fine tune the setting next time you go ride?
I am asking as I never altered the Tps in any of mt Yamaha.
Should I? My 450 snaps my head back from acceleration now.

  • zlathim

Posted November 18, 2011 - 04:04 PM


I called the local stealership today. A new TPS is $273 + tax.:busted::banghead:

I guess I'm leaving mine unplugged.

  • byggd

Posted November 20, 2011 - 07:51 AM


I called the local stealership today. A new TPS is $273 + tax.:lol::banghead:

I guess I'm leaving mine unplugged.

Found one for $208. Still WAY too much IMO.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Sknight

Posted November 20, 2011 - 09:26 AM


I sell TPS units for a living. That's highway robbery plain and simple. I may have to look and see if I can figure out what the car equivalent is.

  • zlathim

Posted November 20, 2011 - 09:51 AM


Found one for $208. Still WAY too much IMO.

I agree. i was thinking $40 would be too much. Shows how much I know.

I sell TPS units for a living. That's highway robbery plain and simple. I may have to look and see if I can figure out what the car equivalent is.

That would be most excellent!:lol:

  • Sknight

Posted November 20, 2011 - 01:14 PM


TPS units are typically $50-100 or so, my Hayabusa needed one and I figured out that one for a Suzuki car would probably fit. It was stolen before I could go do some comparing.

I'll get a look at mine and see, I can promise that my company would love to bring an item to market at half the dealers.

  • GCannon

Posted November 22, 2011 - 08:46 AM


Check for TPS compatibility with R1,R6 and FZ1 (which had carbs) you may get lucky.

  • Rich_in_Orlando

Posted February 19, 2012 - 09:07 AM


Don't know if this applies but while searching this forum for "TPS" I ran across this thread.

I just rebuilt my 99 WR last month. During the downtime I disassembled the carb so I could put it in a bucket of carb cleaner. (Disclaimer: my 99 is fed by a carb from an '04 WR450 that bolted right in and ran great with stock '04 WR450 jetting.) The bike drowned in the swamps of west central Florida last summer so everything had to be cleaned. When I reassembled the carb I evidently did not put the TPS back on properly. The bike runs great after the rebuild, which included a valve job and head porting in addition to upgrading the piston/cylinder/con rod to OEM 426 parts, except for right at idle. It also was hard to start when hot.

ok, I'm getting to it...

My suspicions about the starting and idle problems fell to the float level and TPS setting. I confirmed that the fuel level in the bowl was too high so I adjusted it to 9 mm per Keihin specs.

Then I checked the TPS. My '99 manual says resistance across the blue and black wires (Rbb) should be between 4 and 6 kOhms. My Rbb was good at 4.7 kOhms. Then you use that reading to determine what the resistance across the black and yellow wires (Ryb) should be. The formula for the Ryb range is Ryb = Rbb x (0.13 to 0.15). So Ryb should be between 0.61 and 0.71 kOhms. Ryb measured was an open circuit. Hmmm.

I took the TPS off and looked at the mechanism. There's a tang coming off the throttle wheel shaft that turns a mechanism inside the TPS. The mechanism in the TPS can turn either direction. Using a small flat-bladed screwdriver if you turn the mechanism far enough in either direction, you can feel it click. When I turned it till it clicked in one direction, it started to have spring resistance in one direction. But looking at the way the tang on the throttle wheel shaft turned, I realized the spring force was in the wrong direction. So I turned it the other way past the click and it became springy in the proper direction. After that it was just a matter of lining up the tang and the sensor. I was then able to adjust the Ryb to 0.65 kOhms and Ryb changed as it should have when opening the throttle.

The moral to this story is your TPS may not be bad, it may just need some adjustment above and beyond just the angle adjustment.

BTW, the combination of the two adjustments seems to have made a difference. It idles much smoother now and throttle response seems crisper. I have to get it out in the woods to know for sure but a run around town for a few minutes last night indicates an improvement.

  • GlennR

Posted March 21, 2012 - 03:57 AM


My bike ran extra crappy on the ride home after a few hours of hill climbing through rocks & boulders. It was really sputtery cruising home (pretty slowly & mostly standing because my arse was beat to hell!), also had to switch to reserve at only 38 miles.

How is the TPS actually "adjusted" ? The manual talks about checking ohms on various wires, but I don't think it mentions a way to adjust the TPS. From what I have gathered here I is fine to just unplug the TPS and forget it, or I can pull it off and play with the slotted thing and see how the movement is on that. I wonder why the TPS is so Expen$ive?

  • William1

Posted March 21, 2012 - 10:38 AM


Before a TPS is adjusted, you want to also ensure the throttle shaft is in correct relationship to the slide. This also affects the operation of the AP. I have seen a few where the TPS tested fine but could not be set in range. This was because the throttle shaft was out. If you have never had the slide out or over centered the throttle, yours is probably Ok.
Adjusting a TPS is simple., As RC states, stick pins in the back of the connectors and hook it up. First, with it unplugged, do a range and resistance check. Then with it plugged in and the bike running, adjust it. Adjustment simply consists of loosening the torx screw and moving the TPS. Once it measures right at idle, tighten down the screw, blip the throttle a few times and recheck. Shut off the bike and redo the range test, it should be fine.

Never take the TPS off unless there is a good reason to do so. If you must ride without it operating, simply unplug it and cover the now exposed plugs. A bike with a properly operating TPS will idle better and have more power.

  • GlennR

Posted March 21, 2012 - 08:04 PM


Thanks for the explaination.

I just unplugged mine today, which helped a lot.

I saw the TPS and wondered how you can get the torx bit in there to loosen the unit. I didn't have time to test it today, but I will soon.

  • Do I Care?

Posted March 13, 2013 - 04:34 PM


Found one for $208. Still WAY too much IMO.

Not to bring an old topic to life can buy the tps cheaper CLICK HERE


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.