2003 YZF450 clutch replacement problems


1 reply to this topic
  • RenoMike

Posted October 22, 2011 - 01:19 PM

#1

I searched and am sorry if this has been resolved elsewhere but I couldn't find any info that helped.

So, clutch replacement. Bought EBC clutch plates. Laid bike on it's side, pulled clutch cover, removed clutch spring bolts and clutch hub. Removed all the old friction plates and steel plates. Put in NEW friction plates (soaked over night in oil) with a friction plate first, and then the steel plate, alternating till they're all in. Put hub back on. I had to turn it a bit to get the rod to go in the hole. Put in new springs and bolts, torqued them down to 70 inch lbs (5.8 ft lbs). Clutch cover back on. Started bike on stand. Let run for 10 seconds or so, pulled in the clutch, knocked it into gear and the tire turns like the clutch is not working.

There is pressure on the clutch lever. I've adjusted the lever to like 50% slop and taught as a 17 year olds ass and the clutch still won't work.

What am I missing?

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • RenoMike

Posted October 22, 2011 - 02:06 PM

#2

Never mind. I was just not looking at it right. On the stand, clutch in, can't turn the rear wheel by hand. Started it up, clutch in, bike in gear and pushed on the rear brake and it didn't stall.

Just a new clutch i guess. Rode it slowly down the street and it works fine.





Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.