Help WR 450 Cutting out after AIS kit


3 replies to this topic
  • Barry22

Posted October 09, 2011 - 08:02 PM

#1

I just got my 08 WR 450 back from the dealer who installed the AIS kit. It ran great first 30-45 minutes. Then after a few open throttle runs (drag racing my friend on his DRZ 400) it started cutting out and losing power like it was starving for fuel or air. I live in Dallas,Texas so I don't think the jetting is a problem. After continually working the throttle more the loss of power goes away and then randomly happens again throughout the day. I didn't have them remove the gray wire on account of what I read is that it is just a rev limiter. My fear is that I will climbing a hill and it will start cutting out again. Does anyone have a suggestion? :thumbsup:

Thanks
Barry

  • CanadianWR450

Posted October 10, 2011 - 04:25 AM

#2

the grey wire is a more aggressive ignition mapping from the CDI.
Not sure this is the root of your issue though...
You didn't say if you installed the jet's and needle that come with the AIS kit.
The first thing I would check though is that your fuel tank vent is working properly and it's not causing a vacuum in the tank starving you of fuel during harder running.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Krannie McKranface

Posted October 10, 2011 - 05:11 AM

#3

I just got my 08 WR 450 back from the dealer who installed the AIS kit. It ran great first 30-45 minutes. Then after a few open throttle runs (drag racing my friend on his DRZ 400) it started cutting out and losing power like it was starving for fuel or air. I live in Dallas,Texas so I don't think the jetting is a problem. After continually working the throttle more the loss of power goes away and then randomly happens again throughout the day. I didn't have them remove the gray wire on account of what I read is that it is just a rev limiter. My fear is that I will climbing a hill and it will start cutting out again. Does anyone have a suggestion? :thumbsup:

Thanks
Barry


Yes, take it back and make them fix it while you wait.

  • Barry22

Posted October 10, 2011 - 05:12 AM

#4

Thanks. I will check that. I did have the dealer install the jets and needle that came with the kit.

Barry




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.