Cylinder peeling 2010

3 replies to this topic
  • mx369

Posted October 08, 2011 - 01:55 PM


Bike just hit 50 hours. time to rebuild and found cyl peeling. Valves dead on. Piston look great. Bike ran great. No smoke. Anybody else?

  • rickallen124

Posted October 08, 2011 - 05:07 PM


Please post some pictures if possible.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • grayracer513

Posted October 09, 2011 - 07:30 PM


I recall one guy with an '07 had that problem. Doesn't come up often at all.

  • eazrider

Posted October 09, 2011 - 07:42 PM


I'm confused...why on earth would someone think at 50 hours it is time to rebuild ?? Obviously, you had an issue with your new motorcycle, but "time to rebuild"..?? I just pulled my 2010 apart at 115 hrs to install a WR 4-5 gearset, checked the end gap on the rings, factory spec was .012 new, and mine was a tight .013. My '04 never needed the valves adjusted in 6 years, the guy I sold it to took it in for a top end, just for the heck of it, while the piston and rings were still within spec, he replaced them, along with the cam chain and rubbing block, the valves still were within adjustment needed after 6 years of hard use. I guess if it makes you feel better, it's worth pulling apart at 50 hours, but I'm curious, how did the old parts measure out..??

Related Content


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.