07 hard start with occasional back fire and wont idle

3 replies to this topic
  • Family Man

Posted October 07, 2011 - 07:18 AM


07 hard start with occasional back fire while trying to start it and wont idle once it gets going. It is easier to start once it gets warmed up but it still wont idle. Any Ideas?

  • MxSkater86

Posted October 07, 2011 - 10:13 AM


Whens the last time you checked the valves? or the last time you replaced the timing chain?

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • tech24

Posted October 07, 2011 - 10:15 AM


does it run ok otherwise?

  • grayracer513

Posted October 07, 2011 - 10:16 AM


If it's been a while, check the valves and have a look at the timing. If the bike has been sitting, you probably have a varnish build up in your pilot jet, making it act a couple sizes smaller, or just plain stale gas.

Related Content


100 hrs on 2014 yz450f, shim valves or replace them? by ttr230rider6

Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • Hot  79 replies

First Hare scramble tips by dhend8

Dirt Bike   General Dirt Bike Forums   General Dirt Bike Discussion
  • Hot  33 replies

Need help by Goforaride

Dirt Bike   Dirt Bike Technical Forums   Suspension
  • Hot  68 replies

Michigan Motocross Tires by 288yz450

Dirt Bike   Dirt Bike Regional Discussion   North
  • 1 reply

Help with 2000 yz426 by weekend woods racer

Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • Hot  36 replies

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.