1999 yz400 issues

4 replies to this topic
  • jrdlttl

Posted September 14, 2011 - 09:59 AM


so the bike was stored for a long time appearantly and didnt run. gas was bad and it needed some tlc. so i drained and replaced the gas. changed alll the oil and tried to start the bike. well after alot of kicking it finall would run and ran well. only had it on about 10 mins and shut it off. mind you the thing wouldnt idle regaurdless of where the idle screw was. so that was 3 days ago. yesterday i go out and change the clutch cable then try to start the bike and it wont start. gas is dripping outta the overflow pretty quick and it just wont go. i do the typical early model 400 kick procedure. top dead center than kick. wondering why after sitting so long then starting for me, it could be harder a few days later. input would be great. thanks

  • jojo1224

Posted September 14, 2011 - 11:36 AM


If it has sat for long the carb will need a good cleaning. Gas leaking out of the float bowl would indicate the float is sticking or the float needle is worn. One thing you can do is get a carb rebuild kit, it will include all new jets, needles and orings.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • dfeckel

Posted September 14, 2011 - 01:36 PM


It's likely you have a clogged pilot jet. I'd start there. Get the PJ out of the carb, soak it in a little carb cleaner, then take a strand of very fine wire (strip the insulation from a 2-inch length of wire, and use a single strand to clean out all the passages in the PJ). This will likely fix the starting problem.

  • jrdlttl

Posted September 16, 2011 - 02:59 PM


awesome spending my saturday on the carb then. thanks guys. let u know how it goes.

  • 1991CR250RBEAST

Posted September 16, 2011 - 06:47 PM


Mine sat for quite a while too,had all the same issues.I've had the carb off over 5 times.Completely stripped,cleaned and blew out all the passages with compressed air.It's not spitting or popping anymore since I put in the stock main jet,I ordered a pilot but they sent the wrong one and I believe that is the only reason mine won't idle.By the way search for the "taffy mod". I did it and have no more bog on the bottom.

Related Content


yz400f throttle bog by yz400fmaniac

Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • * * * * *
  • Hot  28 replies

YZ450F 03 Sparks driving me crazy by SirAttard

Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • 5 replies

Is the 2016 GYTR Yamaha YZ450F too fast? by Fryboy

Dirt Bike   Special Interest Forums   Pro Racing
  • * - - - -
  • Hot  241 replies

yz250x vs 450 4t comparisons (preferably desert riding) needed by JakeNorthrupYZ450F

Dirt Bike   Make / Model Specific   Yamaha   Yamaha 2-Stroke
  • 9 replies
WR Camshaft Swap Info - last post by jamesm113

WR Camshaft Swap Info

  • 0 replies

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.