how to get lights on my 426?

5 replies to this topic
  • hank the tank

Posted August 06, 2011 - 02:33 PM


I have a 2000 yz426f that I want to run lights on. dose anyone know how to do this easily? what do I need to do such a thing? has anyone else done this? thanks for your feed back!:eek:

  • Stinger1133

Posted August 06, 2011 - 05:44 PM


There are a few topics regarding this on the forums. I know you need a higher output stator like the one in this link . You can also get one for a WR from ebay. I see them pop up every so often.

  • Ryan426

Posted August 06, 2011 - 07:04 PM


I run a stator off a wr426.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • hank the tank

Posted August 07, 2011 - 05:05 PM


thanks! I will start looking for one. was it much work to install?:eek:

  • RickyStator

Posted August 08, 2011 - 10:00 AM


Dont bother with one in the link, they put out 20 watts at 5000 RPM. Get a WR stator and flywheel and you will be happy. You will need to modify the stator to make it work with your YZ CDI.

  • Stinger1133

Posted August 08, 2011 - 01:39 PM


I just posted that link as an example. That would not be a very good one to use.

Related Content


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.