2007 yamaha yz450 weird one

5 replies to this topic
  • drtjmpr17

Posted July 24, 2011 - 04:24 PM


Washed my bike, did an oil change, rerivited the exhaust tip ( aftermarket little guy to make me legal) and put it on the trailer. Went to moses ran just fine.. it died out on one of the dunes and took me an hour to start -- bruised the hell out of my foot.

Got it back and running and rode the rest of the day .. i just thought i lost some power from not having a paddle and it being loose. and when it died it took me about 15 mins of slowly doing the below to get it to start

Now the only way to start it is
Full throttle no choke and roll it to TDC then in the compression let your foot slowly click the first stage of TDC. reset the kick starter and kick it again.

This is the only way mine will start ---

Once its started it sounds like its misfiring and when you rap it out in gear it boggs down and dies. 3rd gear open throttle normally stands me up and i rocket away. now i get thrown forward from no power and it dieing.

THings i have done -
Pulled the carb apart at st anthonys and rejetted thinking that was the cause.
---nope --
checked timing and valves..
---nope --
changed spark plug and put a new airfilter in
-- nope --
Pulled the muffler off incase it was clogged
-- nope --

im at a total loss.. only thing i can think of is compression now : ( any thoughts?

  • drtjmpr17

Posted July 24, 2011 - 04:43 PM


i don't think it is compression but never know -- it feels like too much compression almost. if i don't let it tick past the TDC the kick starter will not move it has to go slowly, like weight of your foot slowly. Then it kicks over just fine.. you have to reset this and do it again if it didn't start. Never had this issue till now.

  • grayracer513

Posted July 24, 2011 - 05:21 PM


Too much compression? Check the timing again.

Otherwise, check for a loose or cracked stator.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • drtjmpr17

Posted July 25, 2011 - 03:28 PM


rechecked the timing now that we are home and low and behold it looks like the exhaust cam is off a tooth.

Gonna have to buy the book and double check all the marks or search the forums for some photos but it looks like its off 1 tooth.

Gonna buy a new timing chain as i think mine may have stretched.

  • Yamiryder

Posted July 25, 2011 - 03:33 PM


If it jumped a tooth, than more than likely it's stretched.

  • bnichols87ss

Posted August 09, 2011 - 09:45 PM


Same exact thing happened to me. Just slap a new chain in there and that will solve your problem. You probably have a "kinky" chain. Seems to be happening to alot of people.

Related Content


2016 YZ450 by CaptainKnobby

Dirt Bike   Dirt Bike Technical Forums   Suspension
  • Hot  59 replies

Is the 2016 GYTR Yamaha YZ450F too fast? by Fryboy

Dirt Bike   Special Interest Forums   Pro Racing
  • * - - - -
  • Hot  241 replies

yz400f throttle bog by yz400fmaniac

Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • * * * * *
  • Hot  28 replies

Chubby dad, looking at bikes , First trip to the orange/black forum ! by Slow_ride

Dirt Bike   Make / Model Specific   KTM   250-530 EXC/MXC/SXC/XC-W/XCR-W (4-Strokes)
  • Hot  28 replies

YZ450F 03 Sparks driving me crazy by SirAttard

Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • 5 replies

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.