Clutch cover clicking noise

1 reply to this topic
  • Guest_Guest_*

Posted June 05, 2001 - 08:52 AM


I have a strange clicking noise coming from behind the clutch basket cover, it happened instantly after a rock hit my case at low speed. I shut the bike down instantly and I coasted to the garage, I started it up again and same noise but I can feel that when pushing the clutch cover in the noise gets quieter. Unfortunately I didn't have time to pull the cover off and investigate but does anyone have any idea, could a spring have broke, there doesn't appear to be any damage where the rock hit the motor. Any thoughts would be appreciated.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • calamari_racer

Posted June 05, 2001 - 09:10 PM


You might have a broken clutch plate. The rock wouldn't have done that, it was probably a coincidence. I had a clicking noise on my 400 like what you describe, and that's what the problem was. I took the cover off and everything looked normal, so I started taking the clutch plates out one at a time. When I got to the 4th or 5th plate, there was the culprit. It was broken and had a couple of pieces laying around. So I just took them all out, replaced them with new plates and bingo! No more clicking noise. Chrisis averted. Hopefully, it will be something simple like that for you. Post back when you find out and let us know.

[This message has been edited by calamari racer (edited 06-05-2001).]

Related Content


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.