1999 yz400f popping and banging under load??


9 replies to this topic
  • webby06_2007

Posted July 03, 2011 - 11:20 AM

#1

hi new to the forum and from the UK,

i brought a 1999 yz400f today tested it up the road was running fine got it home and over the field started it went up the field and it started spluttering though rev range im going to change spark plug tomorrow fresh fuel as it has been standing for a few months and clean carb out is there any other problems that it could be?? i also noticed that if you lean bike side to side the revs pick up slightly and when its upright it ticks okish did die for no apparent reason on the spot earlyer too??

would be great if someone could offer some advice,

hope you can understand me im a bit of a newbie on forums and computers lol :thumbsup:

  • saveahondafoundation

Posted July 03, 2011 - 11:28 AM

#2

sounds like bad gas , the most common culprit. or a burnt or tight exhaust valve

  • webby06_2007

Posted July 03, 2011 - 12:14 PM

#3

i hope new plug and fresh fuel solve the problem i really do, it almost feels like it cuts out and back in loads pops and bangs does it under loads but doesnt seem to bad on the spot!

  • l_campionero

Posted July 03, 2011 - 12:18 PM

#4

Check the valve clearances....I bet you'll find one or more that are too tight.

  • QuietFlight

Posted July 03, 2011 - 02:57 PM

#5

Probably jarred some debris in the body free and clogged the pilot circuit. Could need new jets as the pilot is difficult to clean out.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • ttr250dude

Posted July 03, 2011 - 08:56 PM

#6

Use premium no ethonal gas!!

  • webby06_2007

Posted July 04, 2011 - 07:44 AM

#7

update

today i cleaned fuel tank out as fuel smelt a bit stale then changed plug was fine when it was cold pulling well then got up to tempreture and started popping and banging, so something is going rong when its warm :thumbsup:

gonna clean carb out tomorrow and replace jets but im unsure if its going to help might??? any ideas???

  • webby06_2007

Posted July 07, 2011 - 10:00 AM

#8

havnt really got much to update about, ordered a new cdi unit and coil yesterday so they will be hear soon . i cleaned carb out again new jets all standard, having the valve clearances done tomorrow and if that dont sort it im breaking the bike up for spares sick to the back teeth of it.....:thumbsup:

  • ttr250dude

Posted July 07, 2011 - 03:17 PM

#9

The cdi rarely goes bad. It doesn't sound like it'd be an electrical issue to me. Do more research here before you give up. Somebody here will have an answer. Grayracer513 is always really helpful.

  • webby06_2007

Posted July 09, 2011 - 06:51 AM

#10

well changed the the cdi unit and coil and problem solved :ride::banana::ride:
unsure what it was if it was the coil or cdi but tbh i cant be bothered to mess about with it again, as the saying goes if it aint broke dont fix it lol of out to find some muddy fields :thumbsup:





Related Content

Forums
Photo

Megabomb Fitment by 288yz450


Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • 1 reply
Forums
Photo

Snake pit oct 30th by The Anvil


Dirt Bike   Dirt Bike Regional Discussion   California
  • Hot  293 replies
Forums
Photo

Michigan Motocross Tires by 288yz450


Dirt Bike   Dirt Bike Regional Discussion   North
  • 1 reply
Forums
Photo
Motocross

Thinking about Yamaha 250... by Arctic Pride


Dirt Bike   Special Interest Forums   Pro Racing
  • Hot  491 replies
Forums
Photo

The "going back to the other darkside" adventure... by Monk


Dirt Bike   Make / Model Specific   KTM   250/350/450/505 SX-F & XC-F (4-Strokes)
  • Hot  94 replies
 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.