O-Ring Master Link Question

7 replies to this topic

Posted April 15, 2001 - 04:51 PM


I searched the archives first, hopefully didn't miss something. Also noticed that when using the search engine he can't seem to find the URL from the stuff in the list...Maybe I did something wrong?
What I am looking for is hints, tips, tricks, or secrets for getting the darn master link on. I usually pull my chain off every other ride and soak it and clean it real well. But everytime its a pain getting the clip on the master link. I have a hard time keeping the clip slots exposed when trying to install the clip. I Know, I know, I'm a retard! But if you can forgive me for that I would appreciate any non-derrogatory suggestions. Thanks, Paul :)
P.S. I'll even take some derrogatory suggestions if they work! :D

  • YZ400Court

Posted April 15, 2001 - 05:24 PM


I use small vice grips to squeeze the link together. It takes some doing, but it works.
Good Luck

Pretend it's flat and give it the gas.

  • cueball

Posted April 15, 2001 - 05:29 PM


Getting the master link on can be a real bear, especially a new chain/master link with new rubber rings!

Somebody might have something better than this, but it works for me:

Use a small socket & C-clamp to compress it on first. That is, open up a small c-clamp to the width of the chain & small socket or a small nut. Put the outside flat in place, and put the socket/nut on the outside where the first pin will come through. Put the clamp over the link & socket, then tighten.

Do this a little at a time on the front & back pins, and it'll squish into place. It tends to stay in place when you remove it, and putting on the clip is reasonably easy.

Works for me....but maybe there's a better way?

  • Tim_in_WA

Posted April 15, 2001 - 06:02 PM


I've used Cueball's method for years and it works great for me!

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • CAB

Posted April 16, 2001 - 07:41 AM


Same as above, but I use two pair of vicegrips and two 10mm nuts. Crank it down, wait, crank again, and usually the clip goes on very easy.

  • YZ400Court

Posted April 16, 2001 - 11:11 AM


Check out the chain press tool in this page from Baja Designs

Pretend it's flat and give it the gas.

[This message has been edited by YZ400Court (edited 04-16-2001).]

  • MichiganDRZ400E

Posted April 16, 2001 - 01:36 PM


I use vice grips and drill out the plate holes. Just enough to clean the hole. I sure makes it go on easier and I have never had a problem. Also I use WD40 to clean the chain after washing the bike(WD40 displaces water) Here in Michigan cleaning the bike is manditory after almost every ride. 10-15lbs. of mud. O-ring chains are lubed from the inside. Most chain lubes just act as dust and dirt collectors. If I use any lube after the WD40 cleaning I use a light oil like Triflow. Try using the WD40 without lube and you'll be suprised how clean the chain stays.


Posted April 16, 2001 - 04:12 PM


Thanks guys!


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.