No spark at plug.


6 replies to this topic
  • sledtrash

Posted May 06, 2011 - 12:29 PM

#1

Hey all I have an 07 WR450 and I recently was having problems with starting so I started diagnosing electrical components and found out my stator and IGN coil were bad, I've got a ricky stator replacement, (new) Stock yamaha Ign coil, and still no spark. I've double tested the old one's and they are def. bad.

This is the order it went in.

I couldn't get it to start so I pulled my coil off and it had spark, the light was lighting up and everything seemed good. stuck it back in and cranked it over a million times (it seemed like it) and still no luck. So I started testing things. I pulled the coil off and tested it like the manual show's it was way below the proper numbers. Setting it aside I checked out my stator per the manual's instructions and it was bad too. So now I have replaced both of those and I'm still not getting spark. I unhooked the kill switch, and I have tried the main ign switch both on, off, plugged in, and unplugged. Nothing. Not sure but I'm guessing that it is the CDI unit.

Note: This is all kick starting on a dead battery I have deleted the electric start.

  • zibbit u2

Posted May 07, 2011 - 05:19 PM

#2

check your ground (s).

  • sledtrash

Posted May 07, 2011 - 10:48 PM

#3

So I have checked my grounds and still not spark, I've heard that cranking it over without a ground will ruin the ign coil? Is this true?

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • gsa102

Posted May 10, 2011 - 08:37 AM

#4

Try a different spark plug.

Charge the battery and try. Supposedly they will not run with a dead battery, but will run with it unhooked...

  • sledtrash

Posted May 23, 2011 - 06:27 PM

#5

Hey guys so I have spark now, but still no fire. I picked up a cheap unmodified harness so I started over, and I noticed something particular that I didn't before. The Trigger coil's red and white wires on the "ricky stator" stator are crossed at the plugin. the white on the stator side is connected to the red on the harness side. and the red on stator side is to the white on harness side. I'm wondering that because this is hooked up wrong, if it might be telling it to fire at the wrong time. Should I switch those wires and go to it?

The stator came like it is so I assumed that it was correct.

  • gsa102

Posted May 24, 2011 - 08:18 AM

#6

You might want to take it up with them, I don't know if you might fry something...

But if it was my bike, I would switch them and try it.

  • sledtrash

Posted May 24, 2011 - 10:29 AM

#7

You might want to take it up with them, I don't know if you might fry something...

But if it was my bike, I would switch them and try it.


So I switched the poles and then called the tech, and he confirmed that yes they were put in backwards so hopefully tonight I get get this thing running :smirk:


Edit, so I put it all back together and I still can't get it to fire. I'm going to charge the batt and see if it will run. I know they are hard to start but I thought that I could get it to run. But no avail. it's sparking as it gets compression but maybe not enough without battery being charged... grrr this is starting to get aggravating

Edited by sledtrash, May 24, 2011 - 05:38 PM.





 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.