starter click


1 reply to this topic
  • strtdsmallproject

Posted February 22, 2011 - 06:00 PM

#1

I didnt want to hi jack an earlier thread, so here it is..... I was at a race and my starter started to do the "scream" sound when i could get the button to work. By the end of the race i had to kick and push button. i pulled the starter gear and everything was fine.I pulled the starter out and tore it down. I checked everything by the manual, brushes were fine, sanded the armature and lubed the end of the starter shaft. I put the starter back together and installed it. Now i get clicky, but can crank the kick starter over by hand when using the start button. I pulled the battery, charged it, and then had batterys plus check it. Its good. I pulled the valve cover and checked the decomp lever. Its great, smooth, and works like advertised. The relay does one click and holds when the button is pushed. Im at a loss. I have a race this weekend and gonna get it workin this week!:smirk: any ideas would be appreciated:worthy: the starter is comming out again tomorrow and getting torn down again.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • gsa102

Posted February 23, 2011 - 02:40 PM

#2

Check the voltage at the starter post when cranking. If it is 10 v or less, you are not getting enough power to the starter - wiring or relay problem since you already checked the battery. You could also test the starter mounted in a vise on the bench to see if it spins freely or is still noisy.




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.