05 WR450 Backfiring


6 replies to this topic
  • Orange and Blue Family

Posted February 21, 2011 - 04:49 PM

#1

My 2005 WR450 runs well, but over the last year it keeps mildly-backfiring on downhills or decelerating. Have had valves retimed, air filter cleaned and recleaned, plug changed, etc. Bike runs really well but keeps having this same problem.

I asked mechanic if FMF Q2 might need to be repacked, and they said that wouldn't cause the problem.

Any other ideas from the Yamaha Dream Team?

  • Navaho6

Posted February 21, 2011 - 05:34 PM

#2

Have you tried richening the mixture at idle (fuel screw)?

  • CanadianWR450

Posted February 22, 2011 - 02:26 AM

#3

You might be getting a bit of a air leak in your exhaust.
You could try removing the header, and re-installing, using some silicone, and torquing to spec....
Another possibility could be the pilot jet getting gummed up. Try replacing it.

If it seems to be temp, or weather related it could simply need a bit of a fuel screw adjustment...

Did it just start out of the blue?
Is it consistent, or worse some days compared to others?
How long have you had the bike? If it does it in the winter, but not summer for example, I'd say you just need a bit of a jetting tweak.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • byggd

Posted February 22, 2011 - 07:59 AM

#4

The two main causes are cold are entering the exhaust or a lean condition. If the exhaust system is tight and the fuel screw is set correctly it may be time to re-jet.

  • William1

Posted February 22, 2011 - 09:32 AM

#5

Did you check the ACV? It adds fuel when coasting to eliminate decel popping. If it is disabled or not working right that can make a big difference. That and the exhaust leaks are the most common causes on a WR (Along with an open muffler). Gummed jets (not clogged, just a layer of varnish) manifest in hard starting and poor idle.

Do not arbitrarily put in a larger pilot or open the fuel screw. That would make hot starts a nightmare.

  • Orange and Blue Family

Posted February 23, 2011 - 09:27 PM

#6

Thanks everyone for the suggestions. It will take me some time to work through everyone's ideas, but you've given me some great focus areas!

  • tomwr450f

Posted March 22, 2011 - 02:39 PM

#7

It could be the AIS, if it hasn't been removed




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.