High idle...

11 replies to this topic
  • geshields

Posted February 15, 2011 - 11:13 AM


I have a 2007 YZ450F that I just installed a CP 13.5 piston in. I broke it in before the weekend and then raced on Sunday. It was running fine for the most part other than this idle problem. I set the idle, then crack the throttle and it returns to the normal idle. However, when I put it in gear and crack the throttle, the bike will idle high until I either crack the throttle again with the clutch pulled in or put the bike in neutral. I also am using VP u4.4 if that matters. Bike seems jetted just fine while I was racing, slight decel pop when entering corners, etc. Any ideas?

  • dgcars

Posted February 15, 2011 - 12:19 PM


Have you tried setting your fuel screw. This will also indicate whether or not you are using the correct size of pilot jet.

If you are using V u4.4, the norm is to go up on jet sizes.

  • tech24

Posted February 15, 2011 - 12:59 PM


I agree with above hanging idle is usually a lean idle mixture

  • grayracer513

Posted February 15, 2011 - 01:15 PM


The ignition timing differs between neutral and any other gear. Hanging idles are usually always a lean condition, but that can be the result an air leak or tight intake valves as well as jetting. U4 normally needs a richer setup than pump gas because of the very high oxygen content too, so that may be feeding into this as well.

Start by verifying a lack of air leaks (I assume you already looked at the valves), then base lining your fuel screw setting and increasing the pilot size if needed.

  • geshields

Posted February 15, 2011 - 05:52 PM


I will verify for air leaks and then readjust fuel screw. I tried adjusting the fuel screw quickly before the race. I believe I am at 2 turns out right now with a 48 pilot. When I closed the fuel screw all the way in that day, it would quit. It was mid 50's that day at sea level..

  • grayracer513

Posted February 15, 2011 - 10:06 PM


Another possibility is that if the engine was apart for the rebuild for a fair bit of time, it may have a varnished pilot.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • geshields

Posted February 20, 2011 - 06:16 PM


Double checked all the carb settings. Could not detect an air leak. Fuel screw at 2 turns out with a 48 pilot, 170 main jet, red JD jetting needle at their recommended clip setting. No varnishing of the main jet or pilot jet.

  • grayracer513

Posted February 21, 2011 - 07:25 AM


Does the pilot jet set up as it should, with an RPM drop as it gets to around 2-3 turns out?

  • geshields

Posted February 21, 2011 - 10:33 AM


I will check that this afternoon. Did not want to annoy the neighbors at 10pm:shocked:

Just ordered a new hose clamp for the airbox to carb connection, a 50 and 52 pilot, and a 172 and 175 main...

  • geshields

Posted February 22, 2011 - 07:07 PM


I was at the track today and tried from 2 turns out to 4 turns out. As soon as I put it in 1st, the bike would rev up. At home, I drained all the u4.4 and ran pump gas. Still same thing. Idles perfect when in neutral, but put it in gear and it revs up. Jetting seems to be spot on. I asked one of the local shop mechanics and he said to try the TPS. I looked at it and it appears the 2 lines from the factory are slightly off. I will disconnect the TPS and then try it...

  • grayracer513

Posted February 22, 2011 - 07:33 PM


TPS could be the culprit.

Disconnect and try. The timing map is changed from neutral to an in-gear state, but it shouldn't change much at an idle. But, if the TPS value is wrong at an idle (lower than normal) it could throw the map off quite a bit.

  • geshields

Posted February 25, 2011 - 05:25 PM


I tried readjusting the tps by sight only, lining up the mark they made from the factory and it still would idle up when I put it in gear. I disconnected the tps and that fixed the problem. Rode it today at the track that way and it worked fine. Seems to be I need to get out my voltmeter and ohm-meter and do some re-calibrating.

Related Content


100 hrs on 2014 yz450f, shim valves or replace them? by ttr230rider6

Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • Hot  79 replies

Michigan Motocross Tires by 288yz450

Dirt Bike   Dirt Bike Regional Discussion   North
  • 1 reply

Chubby dad, looking at bikes , First trip to the orange/black forum ! by Slow_ride

Dirt Bike   Make / Model Specific   KTM   250-530 EXC/MXC/SXC/XC-W/XCR-W (4-Strokes)
  • Hot  28 replies

Snake pit oct 30th by The Anvil

Dirt Bike   Dirt Bike Regional Discussion   California
  • Hot  106 replies

Need help by Goforaride

Dirt Bike   Dirt Bike Technical Forums   Suspension
  • Hot  68 replies

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.