disabled and broke need yz450 help plz


4 replies to this topic
  • wgmacman

Posted January 14, 2011 - 01:35 PM

#1

bike won't idle with choke off and stalls when not on gas a little has power plus and now while riding no problems maybe a little to much backfiring have cleaned the carb 3 times and replaced the vacuum seal any advice for a slight mechanical guy?

Edited by wgmacman, January 14, 2011 - 01:46 PM.
help


  • ttr250dude

Posted January 21, 2011 - 09:29 AM

#2

Did it start doing this after installing the power now plus? It sounds like your fuel screw isn't properly adjusted, but I'm not a jetting expert.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • grayracer513

Posted January 21, 2011 - 09:50 AM

#3

  • Idle simply set too low
  • Idle mixture not rich enough
  • Pilot jet wholly or partially plugged
  • Hot start plunger not seated


  • ttr250dude

Posted January 26, 2011 - 02:28 AM

#4

Any update?

  • wgmacman

Posted January 27, 2011 - 06:45 AM

#5

well i finally got it going ok with the idle set and mixture screw thank you guys but now i have traded the bike for a nice sand rail since i couldn't ride it long enough to really enjoy but this sand rail is really comfortable for me and i think im going to be very happy and have alot of fun.





Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.