2005 WR450 Wont Start

2 replies to this topic
  • SLOSupermoto

Posted November 11, 2010 - 07:22 AM


I have a CA plated WR that I would ride to school pretty regularly last year. When school got out for summer I let it sit for a bit too long and tried to go for a ride with my girl but had no luck firing it up.

Like an idiot I let it sit for even longer (started a new job and havent had time to tinker). So total sitting time is around 4-5 months now (I feel bad for neglecting it this long).

Last friday I pulled the carb (not completely, just off the boots at the airbox and head). I removed the fuel bowl and pulled all 3 jets, cleaned everything well, and slapped it back together. When i went to kick it over (e-start was removed by previous owner) I still had no luck. But when I sprayed some starting fluid into it it would fire up for a short time (running on fumes).

This tells me it's likely a fuel delivery problem?

What should my next course of action be? Any input would be greatly appreciated...

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • gsa102

Posted November 11, 2010 - 09:28 AM


Open the petcock and fuel drain screw to make sure the float isn't stuck shut. If stuck, clean and test it.

  • SLOSupermoto

Posted November 11, 2010 - 09:33 AM


I know the petcock is working, turned it on when the tank was off the bike. Ill try the drain screw on the bowl when I get home...


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.