Lost timing port plug


3 replies to this topic
  • blindearl

Posted October 16, 2010 - 08:35 AM

#1

Rode my WR450 at Hollister Tuesday....when I was done I noticed my boot had oil splattle and my timing port plug was missing. Could have been gone 20 minutes??? or 2 hours??? Very dusty day and am afraid of the possible damage. Am planning on putting some engine degunking cleaner in and running before changing oil and filter. Any unknowns I'm headed for, or better ideas on how to save myself from disaster?
Also, any tricks or people to talk to to get 2004 WR450 plated or greenstickered as well?
Thanks

  • Flagstaff

Posted October 16, 2010 - 10:20 PM

#2

I'd run a couple of short interval oil changes. To get a WR plated, move to Arizona. $100 mods and maybe $35 fees and you're good on and off road. Oh ya, maybe $120 year in street insurance. Since my sister moved, I won't even pass through Kalifornia any more.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • blindearl

Posted October 17, 2010 - 08:14 AM

#3

Thanks...guy at Yamaha shop spooked me of the worst so thought I'd ask if there was any insight beyond the obvious (if it's still running it's not broke!). Anyhow, family and I are contimplating moving North rather than South, but along those lines....don't miss Kalifornia???? Tough transition job wise or anything? Danka.

  • Flagstaff

Posted October 18, 2010 - 08:39 PM

#4

Never lived in Kali, just visited. Az for 23 years, Alaska before that. May be moving back. Never been in Kali legal, Always armed.




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.