2009 WR450 Computer Problem

4 replies to this topic
  • DesertRat74

Posted October 07, 2010 - 06:35 AM


I recently had my WR450 "uncorked" and after some initial jetting problems it's working great. During a recent desert race, I found that my odometer and speedometer are completely screwed! The mileage shown for one of the loops was over 5 miles off. The hour indicator seems to be right but I really haven't tracked that.

Is there a way to "reset" the computer or at least calibrate it? Thanks for any assistance!

  • gsa102

Posted October 07, 2010 - 08:35 AM


I was on a hs loop about 2 week ago with my 07, and the computer said it was about 12 miles, when the promoter said it was 14.5. I don't know how good the stock one is.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • William1

Posted October 07, 2010 - 09:23 AM


There is a function to add/subtract a percentage to rthe recorded amouint. The idea being is ytou ride a section where the loop master rode and recorded a mileage. You do the sme loop, the percentage difference is the factor you must use to 'zero in' to the loop masters bike, so the route charts agree. See your owners manual for the method to set. Setting both trip meters to the same factor will keep them in agreement of course.

  • Bambislayer

Posted October 07, 2010 - 09:52 AM


Is there no way to adjust wheel size in the computer setup?

I have that feature on my KTM.

  • William1

Posted October 07, 2010 - 01:41 PM


No, wheel size is 'preset'. Speed portion never varies only trip meter by the factorial.


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.