No Compression with new top end.

6 replies to this topic
  • dbehr624

Posted September 24, 2010 - 07:48 PM


Okay guys, I am stumped. I recently put a new top end in my '06 and when i put everything back together there was no compression. I rechecked my timing today and made sure the decompression release was in proper working order. As to my knowledge my valves were perfect when I put it back together. I will pull my head off again this weekend, but I need something else to check. Any suggestions?

  • grayracer513

Posted September 24, 2010 - 08:28 PM


If you remembered to put rings in it, then you need to check your valve clearance to start with. After that, then check your timing again by using a probe on top of the piston to locate TDC. Once you find it, check to see that the mark on your flywheel agrees with it. If it doesn't, you dislodged the flywheel key.

  • dbehr624

Posted September 24, 2010 - 08:39 PM


yeah, i put the rings in, so ill check my valve clearance again. I doubt my flywheel key is dislodged, but its always a possibility i fudged it up somehow...:ride: But thanks for the info gray. if it doesnt work, ill be back.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • dbehr624

Posted October 03, 2010 - 11:10 PM


Well my valves checked okay and flywheel key was in place. Is it possible I put the rings in incorrectly?

  • grayracer513

Posted October 04, 2010 - 07:49 AM


Sure, but it's hard to see how you could have goofed them up so as to have no compression, rather than just low compression.

  • yzf225

Posted October 04, 2010 - 08:04 AM


Are you sure all the shims are in place in the buckets, if they are dislodged it may be holding a valve open.

  • eazrider

Posted October 05, 2010 - 09:24 AM


Pressure test the topend through the spark plug hole and see where it is leaking...

Related Content


yz250x vs 450 4t comparisons (preferably desert riding) needed by JakeNorthrupYZ450F

Dirt Bike   Make / Model Specific   Yamaha   Yamaha 2-Stroke
  • 9 replies

100 hrs on 2014 yz450f, shim valves or replace them? by ttr230rider6

Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • Hot  79 replies

yz400f throttle bog by yz400fmaniac

Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • * * * * *
  • Hot  28 replies

Need help by Goforaride

Dirt Bike   Dirt Bike Technical Forums   Suspension
  • Hot  68 replies

Help with 2000 yz426 by weekend woods racer

Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • Hot  36 replies

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.