WR Starter wearing teeth off !

2 replies to this topic
  • tvrjohn

Posted September 20, 2010 - 02:05 PM


Hi have had a WR450 2004 for 4 years, light use only green laning once a month, but i'm on my third starter because of the teeth wearing off on the 9 tooth pinion.
Is this normal ?

Has anyone else had this problem ?

PS Where can i get reasonable priced starters ?

Is there any alternatives from other bikes ?


Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • crooks420

Posted September 20, 2010 - 04:50 PM


When you have two mating parts if one wears out, the other is also probably damaged. You need to change both damaged parts as a set.
Yes there is definately something wrong, I have an 05 WR450 with about 3700 miles on the clock, and no starter problems. I use the kicker when its cold, and the magic button only to restart when I stall the motor.

Any pics?


  • dang420

Posted October 11, 2010 - 12:55 PM


Ive just noticed this on my 07 as well while doing the cam chain. Found some shavings inside the magneto rotor ( being magnetic) which alarmed me, and the pinion of the starter motor is beat up pretty good ( certainly not what one would want to see after 2100 km of albeit, hard riding)


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.