tight clutch?


3 replies to this topic
  • dubee

Posted September 16, 2010 - 05:27 AM

#1

hello, i got a problem with my clutch its seems like i need a new cable because to pull my clutch lever in is pretty hard and on a good day of riding i always end up with blister on my clutch hand cause it so hard to pull in?

i loosen everything up and moved the wire thru the cable and it feels like butter??:banghead: i got a new cable waitin at local part store but im not thinkin thats the problem?

has anyone else had this problem?

there are no kinks in the cable no holes, etc.

any help would be awesome!!:ride:

oh and its a 02 426

Edited by dubee, September 16, 2010 - 07:46 AM.


  • dubee

Posted September 16, 2010 - 10:44 AM

#2

or atleast what you would try first..

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • brentn

Posted September 16, 2010 - 03:11 PM

#3

Try lubing the cable, pulling it when it's not under load of the clutch springs is one thing, and pulling it when it's off the bike is another.

Hold it vertically and spray cable lube into the top and move it up and down. Keep on doing this for about 10 minutes until fluid starts to come out of the bottom, this will tell you that the entire cable is lubed.

Do this first.

  • dubee

Posted September 17, 2010 - 05:28 AM

#4

alright ill try it first thakns alot





Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.