04 WR450 TPS Adjustment


5 replies to this topic
  • miweber929

Posted August 18, 2010 - 04:55 PM

#1

Went to adjust the Throttle Position Sensor tonight following the manual and got very weird readings.

Using my known good Fluke 77 I saw like 4.6 volts at the "stock" position and was only able to lower it to 3.5 volts. I triple checked the Yamaha instructions, can anyone give me a hand?

Resistance did measure within spec.

Mike

  • miweber929

Posted August 20, 2010 - 04:27 AM

#2

Nothing?

I searched around a bit before asking and I didn't see anyone seeing anything like I see with such a high voltage. Am I on the wrong wires? Book stated yellow positive lead and blue negative lead.

Any help would, well, be helpful if you've had this happen.

  • miweber929

Posted August 22, 2010 - 04:39 AM

#3

Found my issue, was reading the words but going by the pic. You need to check between the black and yellow, not blue and yellow. I read it several times but for some reason it wouldn't click in my head.

Set it for .73 volts, still surges at steady throttle. Oh well!!!

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • William1

Posted August 22, 2010 - 01:14 PM

#4

If the surge goes away with the TPS unplugged, reconnect the TPS AND the grey wire and retest. If the surge goes away or is insignificant, it is the CDI and all you can do is get an aftermarket (not a OEM replacement) CDI. However, if after reconnecting verything the surge is just as bad or if the surge is there with the TPS disconnected, you have a jetting issue. Now, depending on the exact throttle position (use tape on the bars and the grip with marks to determine) we can tell where on the needle this is happening and make recomendations as what to do.

  • miweber929

Posted August 22, 2010 - 04:48 PM

#5

Surge is VERY small to non-existent with the TPS unplugged. Was hoping an adjustment would help but it's pretty much the same.

I am going to verify jetting once I have a chance to pull the carb. Bike runs great and the PO seemed to have done his homework with regards to jetting, but I need to be sure

Pretty sure it's just the "normal" WR surge at constant throttle.

What aftermarket cdi is available for this bike?

  • William1

Posted August 22, 2010 - 05:01 PM

#6

Two units I know of off the top of my head, Dynek and Vortex. Vortex is the best choice.

No need to pull the carb, all you need to do is get the needle out, give me the code from it and the alt. and temp you ride at.




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.