how do i test my reg and stator 98wr400

7 replies to this topic
  • darky82

Posted August 12, 2010 - 12:54 AM


how do i test my reg and stator on my 98 wr400 lighting curcit has no power not sure if its reg or stator, was attempting to install bat, bike has no factory bat only ac from stator. before this turn signals wore dim with lights on until revs pick up slightly was also running twin 50w hollogen head lights. :banana:

  • Newfoundlander

Posted August 12, 2010 - 02:54 PM


To test the regulator /rectifier unplug the wires going from it going to the lights and measure voltage across the yellow and black wire should be 13-14volts at 5000rpm as far as I can remember. To test the stator you need to have the bike shut off and test for resistance from the yellow wire coming from the stator to the regulator and measure this wire when disconnected from the regulator to ground. On my wr250f it is 0.224 to 0.336 ohms. This is a possibility but since you were looking at the wiring you may have a ground.

  • darky82

Posted August 12, 2010 - 05:49 PM


set my meter to the upside down horse shoe thing on 200. and betwen the yellow and the black wire fron the stator i get 01.1 is this correct with reg disc

  • Newfoundlander

Posted August 12, 2010 - 05:54 PM


set the ohms to 20 should do it put one end on the yellow wire the other ground out on the frame (bolt etc)

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • darky82

Posted August 12, 2010 - 06:03 PM


my meter has 2000k 200k 20k 2000 200 on the 200 i get the 01.1 and on the 20k i get nothing

  • Newfoundlander

Posted August 12, 2010 - 06:14 PM


That may be ok try starting the bike with the meter changed to V~ this is AC voltage and put the leads on the yellow wire and ground it on the frame. You should get a voltage.

  • darky82

Posted August 12, 2010 - 06:55 PM


just tryed this test and got around 23v

  • darky82

Posted August 12, 2010 - 10:20 PM


Im guessing the problem was the reg as with this disconected i have power, 23V bloke at the bike shop said thats normal for un regulated power from the stator?????


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.