new to me 98 yz 400 f - TPS help please...

4 replies to this topic
  • BlindLOKI

Posted August 08, 2010 - 09:08 PM


Hello all, first post here, been a lurker for awhile I apologize that my first one has to be a problem, but I'm looking for a little help if possible.

I graduated from MMI so I have a small amount of knowledge/mechanical aptitude, with that said, here is what I'm experiencing.

First recieved this bike and got it to start but it ran really rough, hot and popping. I assumed a good carb clean and I'd be off with an awesome bike/steal. I pop the seat off and the aircleaner is destroyed. Replace it and clean the carby out real good, hook everything back up and start the 4 stroke shuffle. After kicking myself stupid, adjusting the pilot (leak on yamaha?... adj. screw anyways...) trying choke, no choke, hot start, adjust idle knob... nothing. If I do get it to light up its still the same pop pop fizz fizz oh shit its hot! lol

So I go to work do my research.... Never had a bike with a manual hotstart before so I replace the worn out tubing on it, test the button it holds all the pressure I can put to it... Put a freshy plug in it, gapped correctly.... kick kick kick same old song and dance. I got it to run ONCE and it sounded GOOOOD. only problem was I had the choke AND hotstart on hahaha, im assuming a freak accident as it died shortly after and returned to pop pop fizz fizz when I did get it going.

I decided to check the tps, as i havent had a carb bike with those either lol I test the resistance and I'm getting 6.11 k ohms fully closed at about 80 degrees F. spec is 4 k - 6 k at 20 degrees celcius, or 68 degrees F. could this be my problem? i'm really hoping not to have to throw 300 onto the bike right away as the wifey is already pissed I got a new "toy" hahaha I am going to try and kick it tomorrow (too late now) with the tps disconnected and see what happens. Can it run decent without a tps? any way to service/fix it? (i know manufacturer says no but I know you guys got some tricks up your sleeve, right? )

anywho... if no change with the tps disconnected I'll rip the valve cover off and see what my clearances are looking like. (i know i know i shoulda checked these first but I wanna ride... hahahaha)

Well, sorry its long as hell, but any help/insight would be greatly appreciated.

Thank you for your time,


P.S. Excellent site with what seems like a good bunch of people... rare find these days hahah

Edited by BlindLOKI, August 09, 2010 - 08:14 AM.
problem change...

  • BlindLOKI

Posted August 09, 2010 - 07:56 AM



starts and idles fine after disconnecting the TPS sensor. I was suspect because of the reading I was getting from it. Sure enough after disconnecting it starts and idles great with the choke on. :banana: soon as the choke is off it dies, but I think i can tune/clean around that.

what all does the tps do? I'm assuming timing/spark. I'm used to seeing them on FI vehicles where it controls a lot of things but this is my first carby with one.

anywho... ill try to clean/tune around the lean condition and see what happens when i take it out in the field :S I'm assuming it could look like a rodeo bull :eek:

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • grayracer513

Posted August 09, 2010 - 11:22 AM


It's a pilot circuit issue that's causing the bike to die without the choke. Bear in mind that the pilot orifice is so small that just a film of varnish in/on it will cause it to misbehave.

The TPS on a carbed bike does just what it did on a carbed car engine. Don't remember that? Then there's no use in my telling you it works like a vacuum advance, I suppose. The TPS provides load state info to the CDI so it can alter the timing map at part throttle. It's designed so that a high TPS output voltage indicates closed throttle and low voltage indicates full. That way, if it fails open, as it most commonly would, the CDI simply fixes the timing on a 2-D map (engine speed only), and assumes a full load. Thus, disconnecting it has no effect on full throttle performance, and only a little on part throttle.

  • BlindLOKI

Posted August 09, 2010 - 09:04 PM


you are the man, I completely understand now :banana: I had a hunch that this is all it was as the fi models do the same thing when failing open but the fi bikes depend a lot more on it as the maps are more dynamic and actually control how much fuel is being sent, where as with the carbs you pretty much get what the air coming in picks up from the float bowl lol

thank you so much, I appreciate the time you spent to write all that out to a newb :eek:

  • grayracer513

Posted August 10, 2010 - 02:50 PM


Everybody's a newb sometime. It's the one's who never get over it I worry about.

Related Content


Need help by Goforaride

Dirt Bike   Dirt Bike Technical Forums   Suspension
  • Hot  68 replies
WR Camshaft Swap Info - last post by jamesm113

WR Camshaft Swap Info

  • 0 replies

100 hrs on 2014 yz450f, shim valves or replace them? by ttr230rider6

Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • Hot  79 replies

2016 YZ450 by CaptainKnobby

Dirt Bike   Dirt Bike Technical Forums   Suspension
  • Hot  59 replies

First Hare scramble tips by dhend8

Dirt Bike   General Dirt Bike Forums   General Dirt Bike Discussion
  • Hot  33 replies

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.