OK did YZ timing, now have miss at full throttle high rpm, help

7 replies to this topic
  • wrkaholic

Posted June 14, 2003 - 02:41 PM


OK guys, just got back from travel and I did the YZ timing mod. It went smooth thanks to all the help I got from this forum. I rode the bike around the coldesack (sp) and it runs like a raped ape, but, at full throttle, high rpm, it misses. It seems the jetting is off now. I am not sure what to do. Should I go to a 165 main, or should I just move the clip from 3 to 4 position? Thanks in advance for any advice. :D :)

  • Rich_in_Orlando

Posted June 14, 2003 - 03:00 PM


I can't specifically answer you question, but on my '99 I had to lean the main and needle when I went to YZ timing. The jetting was fine with WR timing but after changing to YZ timing, it sputtered and missed badly until I changed the jetting. Hope this helps.

  • Bill

Posted June 14, 2003 - 03:37 PM


Might be slamming into the rev limiter. Get out of the culdesac and treat some of your neighbors to the beast in a taller gear ie 3rd or 4th :) and see if you still have the problem.


  • Indy_WR450

Posted June 14, 2003 - 04:12 PM


Too rich or rev limiter. YZ timing makes the bike rev quicker and hit the rev limiter faster. Shift earlier through the gears and see if that eliminates the full throttle load cutting out ( misfire ). I get it when my main is to rich.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • wrkaholic

Posted June 14, 2003 - 05:34 PM


I do not think it is the rev limiter, but, it sure pulls strong. It wheelies even when I am leaning over the bars. I went to 85 on the paj, but, sudco sent me a 180 and 160 mj instead of a maj. So, I still have the 200 maj in there. It still misses at the high rpm. If I shift earlier, it runs through the gears like a raped ape, no missing. Do you think the 200 maj is causing the problem? Maybe I should richen up the main jet? No popping or backfiring. I still find it hard to believe that it is rich on the top rpm. It is pulling so hard, it must need more gas. But, what do I know?? :)

  • Indy_WR450

Posted June 14, 2003 - 06:45 PM


If you think your jetting is on put in a new plug and prove it. I can tell you to try a slightly smaller main jet to get rid of it. A 200 MAJ will draw more fuel from the same main then a 180 MAJ or a 160 MAJ. I have no choice but to use the fixed 200 MAJ on the WR450 carb. That is why I am leaner than most on the main. I put a 160 in and it feels like I am on the rev limiter. I put the 155 in and I am good. Remember that everyone talks about elevation but no one really considers humidity. We have high humidity summers and that means jetting leaner. I do not understand why no one mentions this on this forum. Good luck with it.

  • wrkaholic

Posted June 14, 2003 - 08:45 PM


OK, I get your point. I have a 158 mj and a 155 mj. I will try them with the 200 maj. Do you think 4th position on the EKP needle is too much? Should I go back to 3? It seems to pull wheelies much better with EKP-4 than EKP-3. I will try and then post results. BTW, I am testing at 1850 feet elevation, weather hot, 90 deg., humidity low. :)

  • Indy_WR450

Posted June 15, 2003 - 10:25 AM


I agree with you my bike likes the needle to be in the 4th or 5th position for some reason it does not matter which needle I am using it always runs better in clip #4 and #5 . May be Taffy can give us the scientific reason but I suspect the bike is especially sensitive to needle length.


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.