Yamaha YZ450F oil pressure drive crank seal


7 replies to this topic
  • chriskeit

Posted July 08, 2010 - 12:28 PM

#1

I have recently bought a 2007 YZ450F which has been going great. Very well looked after and all original. When I started it the other day, it started leaking a large amount of oil out the drive crank seal. I have now changed the o-ring under the collar along with the seal (also changed oil filter and oil while at it) and still the problem is there!
I presume there is too much oil pressure which is forcing oil out the sprocket seal?
Help please I don't know what else to do!?!?

  • grayracer513

Posted July 08, 2010 - 12:37 PM

#2

A couple of things come to mind:

  • The collar may have a significant groove worn into it by the old seal, and may be interfering with the new seal.
  • The new seal may not be seated squarely. If it's tilted a little, it may leak because of it.
  • The seal may be inserted too deep. The bore that it sits in has no bottom, and the seal can be pushed in deeply enough that the slots in the collar are even with or beyond the lip of the seal. This will certainly leak. The outer edge of the seal should stand slightly proud of (stick up past) the outer edge of the seal bore.

Too much oil pressure is not the problem. If none of these proves out, check for cracks.

  • chriskeit

Posted July 08, 2010 - 01:01 PM

#3

Thanks for the prompt reply.

The strange thing is that there was no leak at all, then it suddenly started poiring oil out the seal when starting the bike after a week of standing. Like a constant stream of oil not just like a seal beading oil. This is why i presumed it was a pressure thing after changing the seals (and before).

I have checked for cracks and can't see any. The collar has a very slight groove worn, and I was very carefull when installing the new seal, I do think I installed a little deaper than it was when I took it out but far from the edge of the collar etc.

Surely still a leaking seal should leak and not pour? ... only leaks when the engine is running.

  • grayracer513

Posted July 08, 2010 - 03:59 PM

#4

There's only oil pressure when the engine is running. No oil at all when not.

Why do you think the oil pressure would have gone up?

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • chriskeit

Posted July 08, 2010 - 11:35 PM

#5

The engine will run for a few seconds then start pushing oil out the seal between the collar and seal. Doesn't leak oil otherwise at all.

I thought if there was a block in the breather pipe or something then this would cause a pressure buildup and push the oil out?

Someone else said that it would be a bearing... but I don't see what the bearings have to do with oil coming out the seal. But open to suggestions.

  • chriskeit

Posted July 09, 2010 - 12:32 PM

#6

Many thanks grayracer513 for your help.

I have realised after reading through some other threads that you need to have the sprocket on to stop the oil. I presume that the collar is shifting back and forth causing the seal leak.

I have installed the sprocket back on and thankfully has sorted the problem :-)
Still don't know if the seal was to blame to start with, but I am overjoyed that there is nothing seriously wrong!

  • grayracer513

Posted July 09, 2010 - 01:29 PM

#7

Many thanks grayracer513 for your help.

I have realised after reading through some other threads that you need to have the sprocket on to stop the oil. I presume that the collar is shifting back and forth causing the seal leak.

I have installed the sprocket back on and thankfully has sorted the problem :-)
Still don't know if the seal was to blame to start with, but I am overjoyed that there is nothing seriously wrong!

You have to be kidding.

Without the sprocket, there is nothing to prevent the oil pressure from blowing the collar out far enough to leak.

  • chriskeit

Posted July 10, 2010 - 10:59 PM

#8

Thanks for your help.
I realise the error of my way, and understand that I am still a noob at this stuff.
Keep up the good posts Grayracer :-)





Related Content

Forums
Photo

Megabomb Fitment by 288yz450


Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • 1 reply
Forums
Photo

2016 YZ450 by CaptainKnobby


Dirt Bike   Dirt Bike Technical Forums   Suspension
  • Hot  59 replies
Forums
Photo

Snake pit oct 30th by The Anvil


Dirt Bike   Dirt Bike Regional Discussion   California
  • Hot  293 replies
Forums
Photo

100 hrs on 2014 yz450f, shim valves or replace them? by ttr230rider6


Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • Hot  79 replies
Reviews

Yamaha YZ450F 2017 by Chris.GVS


Yamaha YZ450F 2017
  • - - - - -
  • 0 reviews
 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.