2005 YZ450 only runs with choke on?


12 replies to this topic
  • Nitrousman

Posted March 28, 2010 - 06:56 PM

#1

I looked at a YZ 450 tonight that appears to be in really good shape but for some reason it really didn't want to run unless the choke was on. The owner said the bike has sat since last July without being run but that it had Stabil in the gas when it was parked. Has fresh gas in it now but it still only runs with the choke on. Now it was about 35 degrees out so I'm wondering if that had something to do with it? I really can't beat it for the price but I don't want to have a major issue trying to get it running correctly. Could it just be the temperature now or maybe the carb just needs a cleaning? Thanks for any help.

  • 426 NOOB

Posted March 28, 2010 - 07:43 PM

#2

I looked at a YZ 450 tonight that appears to be in really good shape but for some reason it really didn't want to run unless the choke was on. The owner said the bike has sat since last July without being run but that it had Stabil in the gas when it was parked. Has fresh gas in it now but it still only runs with the choke on. Now it was about 35 degrees out so I'm wondering if that had something to do with it? I really can't beat it for the price but I don't want to have a major issue trying to get it running correctly. Could it just be the temperature now or maybe the carb just needs a cleaning? Thanks for any help.


clean the carb and pay extra attention to the pilot circuit.

  • kawatruckermike

Posted March 28, 2010 - 07:55 PM

#3

its old so clean the carp and check the valves

  • ForsheeMS

Posted March 29, 2010 - 07:17 AM

#4

its old so clean the carp and check the valves


Posted Image


Sorry, I just couldn't resist.

  • Nitrousman

Posted March 29, 2010 - 09:03 AM

#5

Thanks guys, if I buy it tomorrow I'll make sure to clean the carp first.

  • Timm

Posted March 29, 2010 - 06:23 PM

#6

now thats funny.First laugh i've had tonight

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Polar_Bus

Posted March 30, 2010 - 08:17 AM

#7

+1,

debris plugged pilot jet.

  • XRfun400

Posted March 30, 2010 - 02:21 PM

#8

I have a very similar story. I just bought an 04 yz 450 back in Dec. and it did the same thing, as soon as you took it off choke it died. I cleaned the carb and it didn't help ended up being the valves,wasn't very expensive and now it runs like a raped ape good luck

  • JandJ07

Posted March 30, 2010 - 05:15 PM

#9

I have a very similar story. I just bought an 04 yz 450 back in Dec. and it did the same thing, as soon as you took it off choke it died. I cleaned the carb and it didn't help ended up being the valves,wasn't very expensive and now it runs like a raped ape good luck


Were the valves out of adjustment or not sealing properly?:thumbsup:

  • Nitrousman

Posted March 31, 2010 - 08:36 AM

#10

Were the valves out of adjustment or not sealing properly?:thumbsup:


What he said? Just the valve lash or did it need a complete valve job?

  • Polar_Bus

Posted March 31, 2010 - 11:36 AM

#11

I have a very similar story. I just bought an 04 yz 450 back in Dec. and it did the same thing, as soon as you took it off choke it died. I cleaned the carb and it didn't help ended up being the valves,wasn't very expensive and now it runs like a raped ape good luck



This simply doesn't make any sense.

  • XRfun400

Posted March 31, 2010 - 02:43 PM

#12

Three out of five of the valves were to tight, after we shimmed them up it run's great.

  • Nitrousman

Posted March 31, 2010 - 06:46 PM

#13

At least it was a simple adjustment. I'll be starting with the carb and see what happens.





Related Content

Forums
Photo

James Stewart back on a YZ450F by YamaLink


Dirt Bike   Special Interest Forums   Pro Racing
  • Hot  47 replies
Forums
Photo

Chubby dad, looking at bikes , First trip to the orange/black forum ! by Slow_ride


Dirt Bike   Make / Model Specific   KTM   250-530 EXC/MXC/SXC/XC-W/XCR-W (4-Strokes)
  • Hot  28 replies
Forums
Photo

Megabomb Fitment by 288yz450


Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • 1 reply
Forums
Photo

First Hare scramble tips by dhend8


Dirt Bike   General Dirt Bike Forums   General Dirt Bike Discussion
  • Hot  33 replies
Forums
Photo

Snake pit oct 30th by The Anvil


Dirt Bike   Dirt Bike Regional Discussion   California
  • Hot  293 replies
 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.