Stuck on high RPM


5 replies to this topic
  • Createnchaos

Posted March 23, 2010 - 03:13 PM

#1

Hey all i got a 2004 yz450f and it starts fine but when i gun it the bike seems to get stuck on high idle for about 5 to 10 seconds. Even after it warms up. Some times the only way to get it back down to idle is to mess with the idle screw. I checked the exhaust for leaks and did find any that i can see. Cleaned the carb and still the bike gets stuck. When im riding the bike its does the same thing but im in gear so that slows the rpm down. Any ideas?

  • Ronus

Posted March 23, 2010 - 03:45 PM

#2

either of these 3 things. Esp if you had the carb off

1. Throttle slide plate is on upside down. Flat side goes down.

2.Throttle slide vacuum seal is on backwards or damaged.

3. Pilot circut is clogged. This usually is accompanied by a red exhaust pipe VERY fast and or low rpm idling problems

  • lbxr400

Posted March 23, 2010 - 05:11 PM

#3

Is your throtle cable boogered up and holding the throtle open, try cleaning the cable

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • JandJ07

Posted March 23, 2010 - 06:49 PM

#4

or try adjusting the idle down and check the pilot screw adjustment

  • grayracer513

Posted March 23, 2010 - 07:03 PM

#5

Read:
http://www.thumperta...365#post9307365

  • Createnchaos

Posted March 24, 2010 - 10:00 AM

#6

Sweet! I did everything but check the valve space and it worked.. not sure what worked but it worked. Thanks guys!





Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.