Cant get AP to squirt

10 replies to this topic
  • gscx

Posted March 14, 2010 - 07:33 PM


I have tried and tried but my spray still isnt looking right . It comes out like this

0000 -----
0000---- -----

The zeros are the carb body, sorry for the crappy "picture" but its the best i got. It isnt really solid, its like a really strong and thick mist, and it jumps up and down also. It sprays kind of far, like 3 ft out of the carb. I have checked everything like 4 times and it all checks out. And the nozzle is clean and everything. I would just get another carb off of ebay but they still go for about 120. Does anyone else have this problem? I just dont understand why it doesnt spray right. The weather is getting nice outside and i really want the bike running right soon, thanks for any help

  • gscx

Posted March 16, 2010 - 09:55 PM


Any one have this problem? I really am at a loss on what to do

  • matt4x4

Posted March 17, 2010 - 07:10 AM


So it's misting too much and shooting far....that tells me you have a partial obstruction in the AP orifice which is breaking up the fuel stream and pushing it through an even smaller opening causing it to come out under a higher pressure.
there's really only one thing you can do - soak the carb (or that particular orifice) for a prolonged period of time, and blow it out FROM the carb BACK to the disassembled AP because it seems like your blockage is near the nozzle but unable to come through the small hole so you will have to try and get it back down the opposite way it went in.

  • gscx

Posted March 17, 2010 - 10:08 AM


Isnt there a check valve in the ap circuit that keeps blowing air from the nozzle down from working?

  • matt4x4

Posted March 17, 2010 - 10:13 AM


You have to take the diaphram off the carb before you clean it all out - and no, not that I'm aware of - it would have to be one super miniature Checkvalve to fit in there!!!! :banana:

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • grayracer513

Posted March 17, 2010 - 10:45 AM


There is a check valve on at least the input side of any accelerator pump to prevent them from pumping back into the float bowl from whence the fuel came. On the FCR carbs, that is located in the pump diaphragm cover. More sophisticated carbs will also have one on the output side to prevent back flow, but I don't recall that the FCR has one or not.

The check valve is not likely to be involved here. I think Matt's original assessment of the problem is probably right.

  • gscx

Posted March 17, 2010 - 01:37 PM


I am sure that he is right. i know something is in it. but i just cant get it out. and using air is not working at all. i dont really think i should soak the carb because i have seen alot of post by eddie saying not to do so because of the gasket that is between the two main pieces of the carb body

  • grayracer513

Posted March 17, 2010 - 01:57 PM


Soaking the carb is bad advice, alright. However, if you locate the passage in the carb body that runs up to the discharge nozzle, you can use a drill bit in a pin vise to GENTLY dislodge any crud that might be lurking up in there. You might also try working a bristle from a fine brass or copper brush through the orifice in the discharge nozzle. Do either of these very cautiously.

And, use compressed air.

  • matt4x4

Posted March 18, 2010 - 03:47 AM


By Soaking the carb I really meant soaking the problem area - just repeatedly (every 10 minutes or so for an hour) drip in enough carb cleaner into the orifice from the AP diaphram side to keep it wet in there - that certainly won't wreck your gasket, once it's soaked long enough try blowing it out in reverse, whatever it is - it may just be varnished to a wall and needs some solvents to break it free.
Grey's idea of using a drill bit or bristle is also good, I just hate to put foreign objects into the passages so be very careful if you do.

  • gscx

Posted March 18, 2010 - 05:59 AM


Thanks for the help guys, ill let you know how it goes

  • gscx

Posted April 03, 2010 - 01:34 PM


So i rode the bike the other day and i got the AP pretty good and the bike runs great. Thanks for the help guys

Related Content


Snake pit oct 30th by The Anvil

Dirt Bike   Dirt Bike Regional Discussion   California
  • Hot  106 replies

YZ450F 03 Sparks driving me crazy by SirAttard

Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • 5 replies

Michigan Motocross Tires by 288yz450

Dirt Bike   Dirt Bike Regional Discussion   North
  • 1 reply

First Hare scramble tips by dhend8

Dirt Bike   General Dirt Bike Forums   General Dirt Bike Discussion
  • Hot  33 replies

Need help by Goforaride

Dirt Bike   Dirt Bike Technical Forums   Suspension
  • Hot  68 replies

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.