WR 450 running like a pig


1 reply to this topic
  • Pecky 1969

Posted March 14, 2010 - 02:44 AM

#1

Howdy guys and gals i have an 04 wr 450 which is running great at high revs but when i throttle off it backfires very badly and blows foot long flames i have replaced the spark plug as well as draining all the fuel from the carby and tank but am wondering if anyone else has had similar problems and their solutions THANKS HEAPS Brendon

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Clays-dad

Posted March 14, 2010 - 06:20 PM

#2

Hey Brendon,
I had the same problem with my 05. After some investigation I found the hot start sticking a little. I took the plunger out of the carb and made sure it was lubed and moved free.....still didn't fix the problem. I finally purchased a cable lube tool and flodded the inside of the cable with a penetrating oil until it flowed clean. Problem solved.

The hot start causes a lean condition which in turn causes the back popping on deceleration.

Deceleration fackfire is also reduced by running premium fuel (US = 92 octane)

Hope this helps




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.