Slide Slow on return

No replies to this topic
  • BubZ

Posted March 06, 2010 - 05:13 AM


Posted in the carb section, wanted to try here as well, any ideas?

I just installed a JD ket kit, an R&D powerbowl and an R&D remote fuel screw on my 09 YZ450. Everything went in without any problems but now that I have the bike back together the slide doesn't snap back after rotating the throttle like it should.

I installed the o-ring from the JD kit on the acc pump link instead of the powerbowl accessory spring, but I don't think that should make a difference.

The throttle moves smoothly and I have looked at everything I can get to without removing the throttle again...any ideas?

Real usual,


Related Content


YZ450F 03 Sparks driving me crazy by SirAttard

Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • 5 replies

Snake pit oct 30th by The Anvil

Dirt Bike   Dirt Bike Regional Discussion   California
  • Hot  35 replies

2016 YZ450 by CaptainKnobby

Dirt Bike   Dirt Bike Technical Forums   Suspension
  • Hot  59 replies

Is the 2016 GYTR Yamaha YZ450F too fast? by Fryboy

Dirt Bike   Special Interest Forums   Pro Racing
  • * - - - -
  • Hot  241 replies

Thinking about Yamaha 250... by Arctic Pride

Dirt Bike   Special Interest Forums   Pro Racing
  • Hot  491 replies

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.