clutch removal issue

3 replies to this topic
  • ch_250

Posted February 15, 2010 - 02:29 PM


i'm rebuilding my WR 426. i'm taking the clutch apart and am ready to take the clutch boss and housing off. the nut and washer are removed but the boss won't come off the splines. it moves about an eighth of an inch and then is stuck. what the heck?

  • Birdy426

Posted February 15, 2010 - 09:37 PM


Sounds like it may have a groove worn in it on the inside...maybe from the lip where the shaft is undercut to start the threads...does it rotate 1/8 inch or move in and out 1/8 inch? I assume by the "boss" you mean the hub (inner portion that's splined to the transmission input shaft. Silly question, but you have the plates off, correct?

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • grayracer513

Posted February 16, 2010 - 10:20 AM


This happens sometimes. The inner end of the splined bore in the boss extends beyond the inner ends of the main shaft splines, and can develop a ledge because of it. You can pull it it with any standard wheel puller designed to pull using three of the clutch spring bolts if necessary, but often all that's required is to give the main shaft an inward rap with a mallet or hammer handle to pop it over the ledge.

  • ch_250

Posted February 17, 2010 - 06:54 PM


makes sense. It's very tight. i'll see what i can do.


Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.