Front brake issue on 98 wr400


3 replies to this topic
  • Lucin253

Posted February 04, 2010 - 04:55 PM

#1

Just bled the front brake on my buddies wr400 and it seemed to loosen the grip on the rotor. After riding just around the block the front brake had almost completely seized, and had to bleed it again to roll it home. New to thumpertalk any suggestions greatly appreciated. Thanks.

  • AZWFO

Posted February 04, 2010 - 10:34 PM

#2

Is it possible the resivoir is filled a little too high creating a back pressure. And even gets worse when the fluid warms up during riding?

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • Lucin253

Posted February 05, 2010 - 12:15 AM

#3

Possibly, that makes sense but I would need to bleed it several more times to see if that could be. The brake fluid level was very high now that I think of it. I'll try bleeding it again and again, and hopefully that will have some effect. Thanks for the reply!

  • Ebola

Posted February 05, 2010 - 07:32 AM

#4

Did he mention that it did that before you did the brakes? You may want to clean out the caliper if it was. The rubber seals can collect dirt behind them and prevent the piston from retracting.




 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.