Gas leak at Accel Pump


2 replies to this topic
  • kevin1209

Posted February 02, 2010 - 06:07 AM

#1

I just bought a 98 YZ400. When I turn on the fuel there is a gas leak where the little rod goes into the accelerator pump (at the rubber boot). Before I tear this thing down, can I get some suggestions on what the problem might be? Is the diaphragm stuck/bad spring/missing O-ring???????

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • grayracer513

Posted February 02, 2010 - 11:05 AM

#2

Ruptured AP diaphragm.

  • kevin1209

Posted February 03, 2010 - 06:04 AM

#3

Thanks. The UPS fairy should be delivering one under my pillow soon.

Also, thanks to Dave Hopkins for the insight and parts help.





Related Content

Wiki
WR Camshaft Swap Info - last post by jamesm113

WR Camshaft Swap Info


Articles
  • 0 replies
Forums
Photo

BIGBORE FOR YZ450F 2006? by Taattie94


Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • 5 replies
Forums
Photo

James Stewart back on a YZ450F by YamaLink


Dirt Bike   Special Interest Forums   Pro Racing
  • Hot  47 replies
Reviews

Yamaha YZ450F 2017 by Chris.GVS


Yamaha YZ450F 2017
  • * * * * *
  • 1 review
  • Last review by Tommyk_55
  • On January 15, 2017
Forums
Photo

Is it worth it? (Cam and High compression piston) by macgi77


Dirt Bike   Make / Model Specific   Honda   CRF 150/230 F/L
  • Hot  36 replies
 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.