clutch problems


1 reply to this topic
  • aaron810

Posted December 12, 2009 - 01:46 PM

#1

i just put a new inner hub and pressure plate with a new clutch in my 06 450 the problem is the clutch wont disengage until the lever hit the grip i was wondering if i need to adjust the plunger thrust washer with a thicker washer because i dont know what else it could be any help would be great also stator has burned out twice dont know why maybe a problem with that year bike and no matter how rich i make the main jet the plug is white like i just put a new plug in it any help with any of these problems would be awesome:banghead:

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • grayracer513

Posted December 12, 2009 - 02:42 PM

#2

Ride the bike for a couple of hours and see if the clutch doesn't get better on its own. Brand new clutches have a tendency to drag a bit until "burned in", especially most of the lower cost aftermarket plate sets.

Your spark plug will always look white if you use unleaded fuel. And of course, the main jet only affects wider throttle openings, so if the idle is lean, the main won't affect that. Read the jetting guide in Common Threads.





Related Content

 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.