yfz 450 running rich?? need help!!


1 reply to this topic
  • binks0678

Posted November 20, 2009 - 08:53 PM

#1

When i first got it, it was hard to start and reved eratically. i took the carb apart and cleaned it and it ran great. now all the sudden its having trouble cold starting (starts fine when warm) and at a constant rpm it missed (but at WOT its perfect). So i cleaned the carb again put it all back together and same problem. could it possibly be running rich and should i adjust that? im 90% sure the problem is in the carb. let me know what yall think, thanks in advance!:excuseme:

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • binks0678

Posted November 20, 2009 - 08:58 PM

#2

forgot to mention when its cold i have to bump start it everytime. and not sure if a header is supose to glow at night?





Related Content

Forums
Photo

James Stewart back on a YZ450F by YamaLink


Dirt Bike   Special Interest Forums   Pro Racing
  • Hot  47 replies
Forums
Photo
Supercross

Wilson the Blue Privateer by jetfuel


Dirt Bike   Special Interest Forums   Pro Racing
  • Hot  50 replies
Forums
Photo

Snake pit oct 30th by The Anvil


Dirt Bike   Dirt Bike Regional Discussion   California
  • Hot  293 replies
Forums
Photo

The "going back to the other darkside" adventure... by Monk


Dirt Bike   Make / Model Specific   KTM   250/350/450/505 SX-F & XC-F (4-Strokes)
  • Hot  113 replies
Forums
Photo

2016 YZ450 by CaptainKnobby


Dirt Bike   Dirt Bike Technical Forums   Suspension
  • Hot  59 replies
 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.