yz400f no spark

2 replies to this topic
  • WR250R2017

Posted November 18, 2009 - 12:47 PM


my yz400 recently has had some sort of electrical problem thats been causing the spark plugs to short out and not spark ruining the plugs but now its not getting a spark at all even with a new plug. does anyone have an idea or what might be going on. is there ways to test the coil or stator or CDI?

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • grayracer513

Posted November 18, 2009 - 02:00 PM


The manual lists the test procedures. Download one:


  • l_campionero

Posted November 18, 2009 - 02:07 PM


That's dang handy! I just downloaded one for my YZ250!

Related Content


Thinking about Yamaha 250... by Arctic Pride

Dirt Bike   Special Interest Forums   Pro Racing
  • Hot  491 replies
WR Camshaft Swap Info - last post by jamesm113

WR Camshaft Swap Info

  • 0 replies

Need help by Goforaride

Dirt Bike   Dirt Bike Technical Forums   Suspension
  • Hot  68 replies

2016 YZ450 by CaptainKnobby

Dirt Bike   Dirt Bike Technical Forums   Suspension
  • Hot  59 replies

Chubby dad, looking at bikes , First trip to the orange/black forum ! by Slow_ride

Dirt Bike   Make / Model Specific   KTM   250-530 EXC/MXC/SXC/XC-W/XCR-W (4-Strokes)
  • Hot  28 replies

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.