2008 Yamaha Yz450 Waterpump problem


2 replies to this topic
  • desertracer49

Posted November 14, 2009 - 06:23 AM

#1

On my bike once I start it up the coolant leaks out of a hole on the bottom of the waterpump cover. It looks like it would be behind the impeller. Could it be the oils seal behind the impeller? Please respond.

Visit the ThumperTalk Store for the lowest prices on motorcycle / ATV parts and accessories - Guaranteed
  • ProjectDIRT

Posted November 14, 2009 - 08:28 AM

#2

if its leaking from the whole the water side seal is bad the whole is an indicator.

  • micahmorgan

Posted November 14, 2009 - 07:01 PM

#3

Sounds like the ol' water pump seals. I recommend you do a search in the yamaha forum for weep hole and/or coolant. You'll find lots of help. You need to replace the seals and likely the shaft too.





Related Content

Forums
Photo

Snake pit oct 30th by The Anvil


Dirt Bike   Dirt Bike Regional Discussion   California
  • Hot  293 replies
Forums
Photo

Should I buy this bike? help....... by Numsa Hul


Dirt Bike   General Dirt Bike Forums   What bike should I buy?
  • * * * * *
  • 10 replies
Forums
Photo

05 yz450f not fast enough by RedeyeYZ


Dirt Bike   Make / Model Specific   Yamaha   YZ 400/426/450
  • Hot  38 replies
Forums
Photo

The "going back to the other darkside" adventure... by Monk


Dirt Bike   Make / Model Specific   KTM   250/350/450/505 SX-F & XC-F (4-Strokes)
  • Hot  113 replies
Wiki
WR Camshaft Swap Info - last post by jamesm113

WR Camshaft Swap Info


Articles
  • 0 replies
 
x

Join Our Community!

Even if you don't want to post, registered members get access to tools that make finding & following the good stuff easier.

If you enjoyed reading about "" here in the ThumperTalk archive, you'll LOVE our community. Come join ThumperTalk today!

The views and opinions expressed on this page are strictly those of the author, and have not been reviewed or approved by ThumperTalk.